Support » Plugin: HTML Editor Syntax Highlighter » Annoying Survey bar

  • Resolved setevoy

    (@setevoy)


    Hi.
    I’m using your plugin a couple and it’s great just – your last Survey bar is really annoying.
    It’s big and the main issue – it won’t disappear even after went by the link and filled the form.
    In fact – I did it once I saw it as I really like your plugin – but the bar is still there. On each page update – it there again and again. Closing it didn’t help. Passing the Survey didn’t help.
    Is it something wrong with my browser (Chromium on Linux) – or it was planned?
    When this Survey will finish and you’ll remove it?
    Anyway – thanks for the great plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi,
    I agree, while the plugin is really useful and I would also like to say thanks, the recent addition of the Survey has turned out to be a big error, for example in our WooCommerce shop it made the Orders list vanish. What our shop managers got instead is just the Survey messages so as a quick fix I deactivate the plugin so that they can work.

    Please notify us over here when we can safely re-activate the plugin. Thank you in advance!

    I would also agree. Need to take a look at this notification issue. It should disappear once clicked or completed.

    One more thing: I have just checked the logs, and in our case the Order list probably was not generated as the plugin caused a fatal error:
    CRITICAL Uncaught Error: Cannot access empty property in .../wp-content/plugins/html-editor-syntax-highlighter/hesh.php:492
    And in hour case there was nothing to click on or any way to start the Survey.

    Plugin Author James Bradford

    (@arniebradfo)

    This notification should only appear once, and disappear for good when closed.

    Try these troubleshooting actions so I can diagnose the issue.

    Go to the Plugin page (not Updates page) and update the plugin to v2.4.0 if it is not already. Then re-activate the plugin if it becomes deactivated. If it does not register that there is an update, please let me know.

    Open the JS console ( Ctrl+Shift+J Windows / Ctrl+Option+J Mac) before closing the notification. Close the notification and see if any errors appear in the console log. Please copy and paste them here if there are any.

    Sorry for the inconvenience. Thanks for helping me fix this.

    I checked the JS Console and no new error appears when the notification is closed.

    We are here to help you short it out. 🙂

    Plugin Author James Bradford

    (@arniebradfo)

    @mixos Can you change other settings and have them persist across a page reload? Try changing the font-size or color theme and then reloading the page. Did the change stick?

    The version already installed – Version 2.4.0 | By James Bradford.
    Disabled and enabled it again.
    Nothing in the Dev Console – after closing the bar with “x” it’s appeared again after the “Update” post button was pressed.
    Screenshot available here: https://ibb.co/hfYQbZN

    • This reply was modified 10 months, 2 weeks ago by setevoy.
    Plugin Author James Bradford

    (@arniebradfo)

    @setevoy Can you change other settings and have them persist across a page reload? Try changing the font-size or color theme and then reloading the page. Did the change stick?

    Yes, the changes in the editor settings stick.

    Plugin Author James Bradford

    (@arniebradfo)

    I found the bug, fixed it, and pushed an update.

    Please download v2.4.1 and the notification will dismiss forever.

    Sorry my survey about user experience gave you a bad user experience. Ironic.

    Thanks for helping me sort this out.

    Thanks for your quick response on this issue. I updated plugin and the notification is gone!

    Best,

    Great!
    The fix worked for me too, thanks a lot.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Annoying Survey bar’ is closed to new replies.