WordPress.org

Support

Support » Plugins and Hacks » [ANN] Enhanced Views plugin

[ANN] Enhanced Views plugin

  • At long last, it’s finally ready for an initial release. Announcing the Enhanced Views plugin for WordPress. This plugin replaces the original Posts and Pages functionality in the WordPress administration interface with new versions that include increased functionality, including:

    * Paging through posts with easy-to-use Next and Previous page links as well as links to individual page numbers.
    * Easily selectable number of posts per page.
    * Browsing by Category, Author, and Date.
    * Sorting by selectable columns.

    This version is an alpha version which does not replace the Pages functionality. That functionality will come in a follow-on release. If you want it, go get it.

Viewing 15 replies - 1 through 15 (of 26 total)
  • Woo hoo! Testing it already 😉

    erm… when I push “Next Page” or the page number, I get shunted to the Dashboard page.

    But “Browse by Category” works!

    Which WordPress version are you on? And what does the URL for the link for “Next Page” look like when it doesn’t work?

    I’m using 1.5 on a local install. The relevant part of the link is this:

    /wp-admin/edit.php?paged=3&showpostsoverride=15&orderby=date&order=DESC

    Weird, looks fine. And that takes you to the dashboard? Does that URL stay in the address box?

    I just tried it out and I get the following errors at the bottom of my magage posts page.

    Warning: ev_posts_display(/home/lawtai/domains/taibros.net/public_html/wp-content/wp-config.php): failed to open stream: No such file or directory in /home/lawtai/domains/taibros.net/public_html/wp-content/plugins/enhanced-views/enhanced-views.php on line 296

    Fatal error: ev_posts_display(): Failed opening required ‘/home/lawtai/domains/taibros.net/public_html/wp-content/wp-config.php’ (include_path=’.:/usr/local/lib/php’) in /home/lawtai/domains/taibros.net/public_html/wp-content/plugins/enhanced-views/enhanced-views.php on line 296

    I’m using Strayhorn and haven’t made changes to core WP files.

    Re-read the installation directions… you’ve installed the files in the wrong place.

    heh oops. Thanks!

    Does that URL stay in the address box?

    No, the URL doesn’t stick. I even cut/pasted it to the address bar and it went to the Dashboard.

    Ah, but I have another clue: when I checked in Safari (I normally use Firefox), it worked ok.

    It *sounds* like the query is going in FF — I hear some disk access noises — just when it gets the result I get pushed back to the main Dashboard page.

    I checked also the “Paged Comment Editing” plug-in, and that works like I expected it to (Next Page = moving to the next page of comments).

    works perfectly for me. would it make sense to add a button to “show all” again rather than having to change all dropdowns back to the default?

    thanks for all your hardwork, this is a very useful function i’ve been looking for since i started using wordpress.

    would it make sense to add a button to “show all” again rather than having to change all dropdowns back to the default?

    Yes, actually it would. Good suggestion, I’ll revamp the dropdown usage for the next release.

    No, the URL doesn’t stick. I even cut/pasted it to the address bar and it went to the Dashboard.

    Let’s try something. Disable the plugin and go to the Manage Posts page. In the URL following “edit.php” put in “?paged=2” and press return. Where does that send you? If it sends you to the Dashboard, then that’s what you’ve got to figure out… I use that same mechanism — which should work — in the plugin.

    Disable the plugin and go to the Manage Posts page. In the URL following “edit.php” put in “?paged=2” and press return. Where does that send you?

    Ok. I first checked that it was still not working. Then I disabled the plugin, added the ?paged=2 and got the next 15 posts.

    So then I re-loaded the plugin, and put ?paged=2 explicitly in the URL, and it worked. So then I pushed the link href and it didn’t work…

    (some time passes)

    And THEN I looked at the front part of the URL after copying it. I’m working on a local install, remember? My path includes ~ — but the Linked URL replaces the ~ with %7E

    It didn’t show on the Status Bar of FF, but it did show when I copied/pasted the link.

    Ah ha!

    I have it activated in the plugins, added the two other files to wp-content/enhanced-views but nothing new is showing in ‘Manage’.

    Not sure what I am doing wrong?

    shadow, make sure you have Javascript enabled.

    ColdForged, you are AMAZING. Actually, I’d use a lot more adjectives before that, but they would all use a 4-letter prefix because I have no words for how incredible this plugin is. I’m still dancing!

    Now, I did run the latest version of One Click Install four times to install Enhanced View and every time it said it installed but the Plugin panel didn’t find it, and I dug everywhere around my site and could find no file with that name, and yet One Click said it was installed and showed the file header information. Very strange. It even uninstalled it with the One Click Remove. But I hunted everywhere.

    Finally did the amazingly simple install with the two little graphic files, and it works like a dream. I’ll be test driving it until it has callouses on it.

    Magic. Pure Magic. I honestly think this should be in the default install. Brilliant!

    Thankyouthankyouthankyouthankyouthankyouuuuuuuuuuuuuuuu

    Later
    It’s not your plugin. I just updated three other plugins and none of those updates are showing up. It’s the One Click Manager…I’ll check there. Thanks!

    Gonna try this tomorrow. Too late to start messin’ tonight. Believe me everyone, there is truly NO REASON to use the “manager” – plugins etc. are super simple without….

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[ANN] Enhanced Views plugin’ is closed to new replies.