WordPress.org

Support

Support » Plugins and Hacks » Edge Suite » [Resolved] Animations with the same ID

[Resolved] Animations with the same ID

  • Someone asked me to look into integrating Edge with WordPress, so I’m testing Adobe Edge and this plugin for that purpose.
    Not knowing exactly what I was doing, I uploaded two test projects to a website and tested them on a single page. Turns out it wasn’t working properly: both compositions had the same ID and were showing the same animation.
    Would it be possible to include a notification for this? When uploading a new composition, you could say something like “A composition with this ID already exists. Using them both on the same page will not work.” or add the possibility to rename a composition (this would be a nice feature in general)

    This plugin has potential, keep up the good work 🙂

    http://wordpress.org/extend/plugins/edge-suite/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Oh, and can you please make translations possible. I would be happy to translate it to Dutch when you do 🙂

    Plugin Author ti2m

    @ti2m

    Hi, what exactly did not work when having two compositions on the same page? You can always use the iframe renderer with shortcodes, but I’d rather avoid that. The stage IDs shouldn’t collide as I’m rewriting them. So not sure what went wrong, in theory this should be posible, would be great if you could give me some more details.

    I’ll look into translation setup.

    Sure, no problem 🙂
    In Edge, I had two animations with “Composition ID” set to “EDGE-18565918”.
    I used shortcodes to display composition 1 on the page, and composition 2 in a widget in the footer. The HTML that was outputted by the plugin was:
    [code]
    AdobeEdge.pathPrefix.comps[‘EDGE-18565918’] = ‘http://www.domain.com/wp-content/uploads/edge_suite/project/test2_2’;
    [/code]
    and
    [code]
    AdobeEdge.pathPrefix.comps[‘EDGE-18565918’] = ‘http://www.domain.com/wp-content/uploads/edge_suite/project/test_1’;
    [/code]
    So since the ID is the same, the pathprefix for the first one is overwritten by the second one and the first composition just shows the animation of the second composition.

    I hope this is clear enough, if not I’ll see if I can set up a test environment so you can see for yourself.

    Plugin Author ti2m

    @ti2m

    Hi,
    thanks for the details. Now I get what you mean. But let me start from the other end, why do you have two compositions with the same stage id? Did you set up one, copy it and alter the second one?

    If you have the same composition id you should have the same resources, at least that’s how I share resources between the same compositions.

    I can’t change the composition id as I think it is pretty hard wired into edge, but I could add a check and notify the user as you recommended.

    Hi,
    a week ago I had no idea Adobe Edge existed. I was looking into it for someone and made some compositions myself. I made a first composition and saved it, then continued with the same composition and saved it under a different name. I had no idea there was such a thing as a “composition ID” when I did that. So that’s why they had the same id.
    An experienced Edge user would most likely not make this mistake, but if you add a notification, that would be great.

    Plugin Author ti2m

    @ti2m

    Thanks for the feedback. I’ve added the feature requests to the main backlog on trello and am therefore closing the feature request here for now.

    Check: https://trello.com/board/edge-suite/507488990084aba17a421fc7

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Animations with the same ID’ is closed to new replies.
Skip to toolbar