Support » Plugin: Animate It! » Animation Causing Page to expand its width

  • jcpacelli

    (@jcpacelli)


    I have animations setup on this site and i’ve noticed that on iOS and Safari on macOS, an element is making the page wider than the screen. In the footer, i have a google map that is supposed to slide in from the right. when it does, it make the page way wider than the screen and enables horizontal scrolling. it does not do this if i disable the AnimateIt plugin.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author eleopard

    (@eleopard)

    Dear jcpacelli,

    Thanks for using the Animate It!

    Some animation have been known to have this kind of effect.
    Please try the following:

    In the WordPress backend, go to Settings > Animate It! and make sure that the “Hide Horizontal Scrollbar:” is set to Yes.

    If it is set to Yes, and the issue still occurs, please add the following CSS in the Custom CSS box.

    body{
            overflow-x: hidden !important;
    }

    Let me know if one of these solutions work for you.

    Thread Starter jcpacelli

    (@jcpacelli)

    Hi, thank you for the quick response. it doesnt seem like either of those suggestions are fixing the issue

    Plugin Author eleopard

    (@eleopard)

    Dear Jcpacelli,

    I checked your page on Chrome and Firefox, and horizontal scroll is not visible to me.

    I also added class slideInRight to Google map box using Inspect element. But it is working fine for me, and no horizontal scrollbar is visible whatsoever.

    Please let me know if I am missing something.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Animation Causing Page to expand its width’ is closed to new replies.