Support » Plugin: Genesis Club Lite » Animated Bar Only Shows on Home Page

  • Resolved MissKitty9470

    (@misskitty9470)


    I have the Bar activated for my website, and it is configured to show on all pages, however, it only shows on the Home page.
    Using WP 4.9.4, Genesis 2.6, and Infinity Pro theme. All plugins up to date.
    Here’s the url (currently very much a work in progress!)

    Any ideas?
    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Russell Jamieson

    (@powerblogservice)

    Please you check your settings on the Genesis Club > Bar > Location tab.

    It is behaving as if you have “Show Only On Home” checkbox set

    What have you set as the HTML element where you are injecting the bar?

    HI Russell, and thank you.
    I apologize, I should have clarified:
    my settings are correct:
    HTML ELEMENT: .site-header
    POSITION: top
    HIDE ON HOME: unchecked
    SHOW ONLY ON HOME: unchecked

    I tried toggling these settings and it still only shows on the home page.
    https://cl.ly/q5EL

    Plugin Author Russell Jamieson

    (@powerblogservice)

    The default behaviour is for the bar to be present on

    • Home Page
    • Posts
    • Category Pages
    • Tag Pages

    The default behaviour is for the bar to be absent on

    • Pages
    • Custom Posts
    • Custom Taxonomy Archives

    The rationale is that on pages which are typically landing pages, privacy, terms, etc you do do not want to distract the user with the bar.

    Similarly on custom post type pages which might be a e-commerce store page you do not want to distract the potential buyer when they are about to put something in the shopping cart.

    However, you can override the default behavior in the Post Editor by either switching the bar on or off as you prefer.

    Plugin Author Russell Jamieson

    (@powerblogservice)

    On your site you have mainly pages, so you need to enable the bar on each page you want it to appear.

    In the Post Editor, scroll down to the Genesis Club Lite Settings section and click the checkbox Show the top bar on this page

    Oh my goodness, Russell, you are a genius!! I should have seen this, I’m so sorry. Thank you so very much.

    Plugin Author Russell Jamieson

    (@powerblogservice)

    Glad to help. 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Animated Bar Only Shows on Home Page’ is closed to new replies.