Support » Plugin: JWT Authentication for WP REST API » android app error while login

  • Sia

    (@siaalborz)


    hi every one. im trying use an android application to login into my WP website
    all plugins are up to date
    my WP version is 5.7.1 and its up to date
    I’m not an expert developer and just a beginner
    when i try to logging in with my app( in android studio virtual device and physical device too)
    the app logger shows this error:

    E/ddad: okhttp3.internal.http.RealResponseBody@a680910
    D/api_: {"code":"[jwt_auth] incorrect_password","message":"error: entered password for username is incorrect ,did you lost it?","data":{"status":403}}
    D/api_headers: {"namesAndValues":[]}
    D/api_response_arrived in: 3 second
    D/api_url: https://www.site.com/wp-json/jwt-auth/v1/token
    D/api_request: {"password":"password","username":"username"}
    D/api_response: null
    D/api_: ------------------
    [jwt_auth] incorrect_password" 

    But , the password was correct, i swear to GOD . it’s correct.
    please help me , i’m gonna crazy
    thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Antonin

    (@antonin)

    I had the same problem and realized that the reason was probably the presence of a single quote character in the password. If you happen to have a quote character in your password, try changing your password to see if it solves it.
    This issue should be fixed if confirmed.

    Thread Starter Sia

    (@siaalborz)

    really appreciated for your attention.my pass phrase is so simple .no special character used.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘android app error while login’ is closed to new replies.