Support » Plugin: Germanized for WooCommerce » Änderungen speichern funktioniert nicht

  • Resolved mister00stooge

    (@mister00stooge)


    Hy,

    wenn ich bei Woocommerce Germanized in den Einstellungen > Allgemein unten auf > Änderungen speichern klicke, kommt ein Dialog > Öffnen von admin.php.

    Dann kann ich eine admin.php Datein herunterladen, oder abbrechen…

    Und natürlich wird nichts gespeichert.

    Bei allen anderen Rubriken von Woocommerce Germanized funktioniert der Button > Änderungen speichern.

    Habe Woocommerce und Germanized deaktiviert und gelöscht und neu installiert, aber das Gleiche.

    Habe auch die Dinge, die unter dem Toppic von schnetzi “Einstellungen speichern funktioniert nicht” ausprobiert, Plugins deaktiviert, wieder aktiviert, aber weiterhin das Gleiche…

    Und habe auch das PHP Memory Limit auf 512MB gesetzt, aber trotzdem der gleiche Fehler…

    Vielen Dank für jegliche Hilfe und Zeit.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author vendidero

    (@vendidero)

    Hi,

    ich denke das liegt wohl an deinen PHP-Einstellungen. Vielleicht reicht deine max_input_vars Variable oder eben dein Memory Limit nicht aus. Hast du mal unter WooCommerce > Status in die Logs geschaut? Insbesondere die fatalen Fehler wären interessant.

    Grüße

    mister00stooge

    (@mister00stooge)

    Danke schon mal, für deinen Einsatz. Ich bin nicht der Backend Crack, aber lernfähig und kann Anweisungen ausführen, um den Fehler zu finden…

    Okay, habe mal bei Status geschaut und die “fatalen Fehler” sind die Dinge, die “rot” sind?

    Poste einmal, was über PHP dort steht:

    WC Version: 3.5.4
    Log Directory Writable: ✔
    WP Version: 5.0.3
    WP Multisite: –
    WP Memory Limit: 512 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: de_DE
    External object cache: –

    ### Server Environment ###

    Server Info: Apache/2.4.37 (Unix)
    PHP Version: 7.2.14
    PHP Post Max Size: 76 MB
    PHP Time Limit: 180
    PHP Max Input Vars: 5000
    cURL Version: 7.50.3
    OpenSSL/1.0.2j

    Habe auch Query Monitor installiert, um bessere Infos zu liefern (wenn ich verstehe, was ich tun muss ;-).

    Plugin Author vendidero

    (@vendidero)

    Hi,

    ich meine die “echten” Logs unter WooCommerce > Status > Logs (das ist ein separater Tab). Dort sollten verschiedene Log-Dateien im Dropdown Menü auswählbar sein. Interessant sind vermutlich insbesondere die fatalen Fehler. Ansonsten müsstest du mal bei deinem Hoster nachfragen, ob der dir die error.log Datei zur Verfügung stellen kann.

    Grüße

    mister00stooge

    (@mister00stooge)

    Okay, der Honk hats gefunden 😉

    2019-02-13T10:03:15+00:00 CRITICAL Uncaught Error: Call to a member function get_base_country() on null in /mnt/web114/d0/95/52154095/htdocs/WordPress_01/wp-content/plugins/woocommerce/includes/class-wc-payment-gateways.php:87
    Stack trace:
    #0 /mnt/web114/d0/95/52154095/htdocs/WordPress_01/wp-content/plugins/woocommerce/includes/class-wc-payment-gateways.php(70): WC_Payment_Gateways->init()
    #1 /mnt/web114/d0/95/52154095/htdocs/WordPress_01/wp-content/plugins/woocommerce/includes/class-wc-payment-gateways.php(43): WC_Payment_Gateways->__construct()
    #2 /mnt/web114/d0/95/52154095/htdocs/WordPress_01/wp-content/plugins/woocommerce/includes/class-woocommerce.php(690): WC_Payment_Gateways::instance()
    #3 /mnt/web114/d0/95/52154095/htdocs/WordPress_01/wp-content/plugins/woocommerce/includes/class-woocommerce.php(146): WooCommerce->payment_gateways()
    #4 /mnt/web114/d0/95/52154095/htdocs/WordPress_01/wp-content/plugins/woocommerce-germanized/includes/admin/class-wc-gzd-admin.php(573): WooCommerce->__get(‘payment_gateway…’)
    #5 /mnt/web114/d0/95/52154095 in /mnt/web114/d0/95/52154095/htdocs/WordPress_01/wp-content/plugins/woocommerce/includes/class-wc-payment-gateways.php in Zeile 87

    Ich hoffe, das ist, was du meinst.

    Komischerweise ging es gestern kurz zu speichern, nachdem ich die Zahlungsarten & Versand Seiten bearbeitet habe, aber heute wieder nicht…

    Plugin Author vendidero

    (@vendidero)

    Hi,

    hm, komisch. Hast du mal die Log-Datei gelöscht/geleert und dann erneut getestet um sicherzugehen, dass dieser Fehler wirklich in Zusammenhang mit der geschilderten Problematik steht? Der Fehler müsste nämlich jedes mal geloggt werden, wenn du speicherst und dein Problem auftaucht.

    Grüße

    mister00stooge

    (@mister00stooge)

    Habe ich gerade probiert.

    Log gelöscht und Fehler gleich, speichern geht nicht, nur die Möglichkeit die admin.php zu speichern…

    Und es gibt auch keinen neuen Fehlerbericht…

    Plugin Author vendidero

    (@vendidero)

    Hi,

    verstehe. Das deutet schon einmal daraufhin, dass der Fehler aus den Logs nicht in Verbindung steht mit dem eigentlichen Problem. Hast du mal WP_DEBUG in deiner wp-config.php aktiviert und erneut getestet? Im Zweifel müsstest du dich an deinen Hoster wenden und fragen, warum keine Logs erzeugt werden bzw. keine Fehlermeldung ausgegeben wird. Das ist nicht “normal”.

    Grüße

    mister00stooge

    (@mister00stooge)

    Habe Debug jetzt aktiviert und Fehler ist weiter da.

    Wie gehe ich weiter vor?

    Plugin Author vendidero

    (@vendidero)

    Hi,

    d.h. dir wird nach dem Speichern immer noch keine Fehlermeldung präsentiert? In diesem Fall müsstest du dich wohl an deinen Hoster wenden und die darum bitten, dir den konkreten, auftretenden Fehler zu nennen.

    Grüße

    mister00stooge

    (@mister00stooge)

    So, ich habe jetzt mal logs in meinem Strato Paket aktiviert und bekomme dann Infos per mail.

    Habe auch diesen Tipp umgesetzt:

    https://blogger-base.net/wordpress-debug-datei-erstellen/

    Werde jetzt mal schauen, ob was in die debug.log geschrieben wird.

    Ich bin echt der stooge, wenn es um diesen Kram geht, aber komme wohl nicht drum herum…

    Danke für deine Zeit, ich schreibe, wenn was im debug.log zu finden ist…

    Hoffe, das alles hier hilft irgend jemanden auch weiter 😉

    mister00stooge

    (@mister00stooge)

    Ach ja, das steht in der php.datei, die ich beim speichern laden kann:

    <!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”>
    <html><head>
    <title>503 Service Unavailable</title>
    </head><body>
    <h1>Service Unavailable</h1>
    <p>The server is temporarily unable to service your
    request due to maintenance downtime or capacity
    problems. Please try again later.</p>
    </body></html>

    So, hier nochmal ein Update, damit es vielleicht irgendjemandem weiter hilft, falls der selbe oder ähnliche Fehler auftritt:

    Bei meinem Hoster (Strato) gibt es einen Filter gegen Gästebuch-Spam im Security Bereich. Dieser hat dafür gesorgt, dass ich nicht speichern konnte und den entsprechenden Fehler bekam. Es gab ja auch Probleme mit der log-Datei, wie oben zu ersehen ist.

    Nachdem ich mit Strato telefoniert habe und der Mitarbeiter mir diesen Tipp gab, konnte ich sofort speichern…

    Juchee!!

    Danke nochmal an vedidero für die Geduld mit dem stooge…

    Sonnenschein und Geduld für alle Suchenden 😉

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.