Support » Theme: OceanWP » Anchors on external page doesn’t work correctly

  • hello everybody.
    i have a problem with the mobile version of a website.
    i have the same menu in all the pages of the site, within various anchors on the sections of my homepage.
    if click it from an external page the last two anchors doesn’t work correctly, take the user to the correct page but not to the correct point of the anchor, bringing it lower.
    this problem appear only for the last two sections/links and only on a mobile version.

    can you help me?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    I visited on your site and the menu anchors are working fine for me on the mobile device. Try to rename the section id and check the page again if it is still not working for you.

    hello,
    i’ve tried to rename the sections id but don’t work correctly again.

    if you navigate from here http://www.caparavento.it/wp/bb/ and you try to go on the about or contact sections form a mobile device (i use an iPhone) anchors don’t works right.

    Hi @nichbarisich,

    I do see a small issue on your mobile site. The link points directly to heading text without padding on top.

    The reason this is happening is because you are using Menu Anchor widget from Elementor and adding padding to the section. So, the Menu Anchor starts below the actual section and menu points to that location.

    Please remove the widget and try adding CSS ID to the section and see if that helps.

    Let me know how that goes! 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Anchors on external page doesn’t work correctly’ is closed to new replies.