Support » Fixing WordPress » Anchors not working (new page links to the anchor but then scrolls to top))

  • Hi,

    I have two versions of the page – German and English, both have a bunch of anchors, linked to the artists biographies. When I stay within the page the anchors work fine, but when I link cross page, the other page goes to the anchor, but then jumps back on top. What can be causing it?

    Thank you!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • From the technical perspective, your anchors are working exactly as they’ve been designed or coded to work.

    All the links from the German page to the respective bios on the English page are linked to EXACTLY THE SAME ANCHOR POINT #shaarbek_amanku_afe — and not to their respective English bios.

    What’s more, this single anchor point #shaarbek_amanku_afe doesn’t even exist on the English page at all, that’s why the links show the top of the page.

    My guess is that you duplicated one button at some point, but did not check to be sure the duplicated buttons are linked to the correct anchor points on the English page.

    Thread Starter memymilk

    (@memymilk)

    Hi, thanks for the reply!
    As for the links – the first ones are actually linked to the different bios, the others were left the same until we figure out the issue, which is causing the problem.

    For example when I click on the anchor inside the English page,
    https://www.momentumworldwide.org/exhibitions/art-from-elsewhere/#aaajiaoAfe – it brings me to the respective part of the page, but if I click on this link on the German page, or try to copy paste this link into the browser, the page first scrolls to this part of the page, but then goes back on top.

    As for the anchor #shaarbek_amanku_afe – there was a spelling mistake, that I corrected, and the link does same thing as above – the page opens to the anchor, but then after half a second scrolls back to top.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Anchors not working (new page links to the anchor but then scrolls to top))’ is closed to new replies.