Ready to get started?Download WordPress


Anarchy Media Player AMP 2.5 Broken in 2.7? (6 posts)

  1. John
    Posted 6 years ago #

    Can anyone confirm that they have AMP 2.5 working in WP 2.7. I see it's listed as a compatible plug-in with 2.7, but I've had problems since WP 2.6.5, where installation incurred a Fatal Error. I was able to get around the installation problem after seeing this Support item: http://wordpress.org/support/topic/214625?replies=1
    but now that I have it installed it doesn't seem to be working at all. Either I have something wonky with my particular installation (tried turning off other plug-ins etc.) or it should be taken off the compatible list until it's updated.

  2. Samuel B
    Posted 6 years ago #

    works well on my blog which went through all of the 2.7 testing and now is using 2.7-stable

  3. John
    Posted 6 years ago #

    Thank You. I just tried a fresh install of AMP 2.5 on a fresh install of WP 2.7 and am still having the problem. I have a hunch it's something to do with the path I had to alter in order to get around a fatal error on installation, so I posted the details to the
    more specific Support item.

  4. iamthechosenone
    Posted 6 years ago #

    It will be your host. I have a problem where the videos do not show up, instead i get a white box. My host refused to accept it was them until I found that it was a mod_sec rule they had applied.

  5. John
    Posted 6 years ago #

    Thank You,
    I'm on DreamHost (and very happy with them overall) and have a query sitting on the Support forum. Perhaps someone more knowledgeable will stumble upon it and find a solution.

  6. Endolith
    Posted 5 years ago #

    I just tried installing it on 2.8.5 and it's not working for me, either. All my other plugins work fine, but when I try to activate AMP, it says

    Plugin could not be activated because it triggered a fatal error.

    Warning: require_once(/home/username/public_html/wp-config.php) [function.require-once]: failed to open stream: No such file or directory in /home/username/public_html/wordpress/wp-content/plugins/anarchy_media/anarchy_media_player.php on line 20

    Fatal error: require_once() [function.require]: Failed opening required '/home/username/public_html/wp-config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/username/public_html/wordpress/wp-content/plugins/anarchy_media/anarchy_media_player.php on line 20

    Lines 19 and 20 of anarchy_media_player.php:

    require_once str_replace($_SERVER['SCRIPT_NAME'], '',
                             $_SERVER['SCRIPT_FILENAME']) . '/wp-config.php';

Topic Closed

This topic has been closed to new replies.

About this Topic