Support » Plugin: Reduce Bounce Rate » Analytics says The Event Tracking Code is not correct

  • Hi Okoth and thanks for all your effort you put in this plugin, I really appreciate it,

    Installed few months ago and all is smooth, except this one: the Google Analytics pops an error message, saying that a “not set” page event is sent to them because sending the page events must be preceeded by a page view, so Analytics know to which page to assign the following events,

    It seems that I’m sending some page events before the initial page view, and these events get “not set” value instead the page that triggered them.

    Before opening this ticket I played a little with the priorities of rbr_scripts and rbr_st_control_vars functions, making sure that they come after the analytics code in the page, then ask Analytics to re-check – with no success so far,

    I also set the Time event to fire every 60 seconds, but it gets fired every 10 seconds, still in the page I see the parameter “var stLogInterval=60*1000;” – so the parameters get rendered correctly in the page,

    I use Yoast & universal, Wordfence caching and Cloudflare, current versions of WP and plugin,
    I prefer to send you the url in private if you’d like to take a look, is it possible?

    Thanks and regards,
    Alex

    https://wordpress.org/plugins/reduce-bounce-rate/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Okoth1

    (@okoth1)

    Hi Alex,
    You can send the url to okoth1 at gmail dot com? Do you 10 million hits per month per property?
    https://developers.google.com/analytics/devguides/collection/analyticsjs/limits-quotas

    Plugin Author Okoth1

    (@okoth1)

    I might not be able to help today. Time…time…time…

    Plugin Author Okoth1

    (@okoth1)

    “I also set the Time event to fire every 60 seconds, but it gets fired every 10 seconds, still in the page I see the parameter “var stLogInterval=60*1000;” – so the parameters get rendered correctly in the page,”

    That part I still need to fix. Not successful so far. If you set it to 60 seconds it renders correctly, but in Analytics it is still written in 10 seconds steps. You have to read it as 60 seconds steps.

    Hi Okoth and thank you for your time,
    There is no hurry, please do not even try to help me today, ok? 🙂

    I do not pass 10 millions hits, I only have 443000 events in the last 30 days as reported by Analytics; if you need more data I am willing to give you access to this property reports in Analytics,

    Regarding the 10 seconds reporting issue – I found other thread about it and I’ll reply there,

    I send you the url now, please let me know if you got it.

    Thanks and regards,
    Alex.

    Plugin Author Okoth1

    (@okoth1)

    I’ve looked at your page and it all looks fine.

    I need a bit of time to figure out what’s happening. I need to see if this is similar to https://wordpress.org/support/topic/urgent-bad-event-tracking-code?replies=4

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Analytics says The Event Tracking Code is not correct’ is closed to new replies.