Support » Plugin: CAOS | Host Google Analytics Locally » analytics no works

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Hi,

    You have autoptimize JS combine enabled, which is causing errors. That’s one.

    But when I add the parameter ?ao_noptimize=1 to the URL to bypass Autoptimize, the collect call is sent, and I see that you have CAOS’ stealth mode lite enabled. However, your server is returning a 403 error. Which means that WordPress’ frontend is not allowed to access CAOS’ collect endpoint.

    You should look into that, or have your hosting provider look into that.

    PS. Also, next time provide a bit more information (e.g. what have you changed recently? Do you have your own suspisions of what might break it?) instead of just “it doesn’t work”, this saves us developers and support teams a bunch of time trying to figure out what the issue is.

    Thread Starter wordgr

    (@wordgr)

    Yes, thank you, but I haven’t changed anything.

    Hi,

    You have autoptimize JS combine enabled, which is causing errors. That’s one.

    But when I add the parameter ?ao_noptimize=1 to the URL to bypass Autoptimize, the collect call is sent, and I see that you have CAOS’ stealth mode lite enabled. However, your server is returning a 403 error. Which means that WordPress’ frontend is not allowed to access CAOS’ collect endpoint.

    You should look into that, or have your hosting provider look into that.

    PS. Also, next time provide a bit more information (e.g. what have you changed recently? Do you have your own suspisions of what might break it?) instead of just “it doesn’t work”, this saves us developers and support teams a bunch of time trying to figure out what the issue is.

    Hi, you’re sorry, but I don’t understand anything about what they’re giving me now.
    Have said. 🙁

    So you think the problem is the server?
    I have Enable Stealth Mode Lite And I think it works again now

    • This reply was modified 1 year, 4 months ago by wordgr.
    • This reply was modified 1 year, 4 months ago by wordgr.
    • This reply was modified 1 year, 4 months ago by wordgr.
    • This reply was modified 1 year, 4 months ago by wordgr.
    Thread Starter wordgr

    (@wordgr)

    What exactly should I mean, Providers say?

    Thread Starter wordgr

    (@wordgr)

    @daanvandenbergh
    The error is gone. Can they confirm that?
    The question is why he came without me changing anything on the side! And the provider hasn’t changed anything on the server either, so lag is a plugin!

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    I think the following might’ve been the problem:

    1) You once enabled stealth mode, updated analytics.js and left Autoptimize to aggregate and minify the analytics.js file,
    2) Then you disabled stealth mode, maybe updated analytics.js, but didn’t flush Autoptimize’s cache, so the ‘old’ analytics.js file was still aggregated in Autoptimize’s cache.
    3) the endpoint wasn’t registered by CAOS (cause it was disabled) but Autoptimize’s cached file still tried to reach it, resulting in the error.

    I still think you should exclude analytics.js from Autoptimize’s JS files, to make sure it functions correcrly.

    Thread Starter wordgr

    (@wordgr)

    Okay I have excluded analytics.js, how do I find out if everything works correctly?

    Thread Starter wordgr

    (@wordgr)

    I’m sorry but I deactivated the plugin it just didn’t lose any more data and I just don’t know why?
    Do I get better support if I buy the CAOS Premium for 39€?

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    I didn’t get a notification about your message from yesterday! Sorry!

    Besides, I have a 40 weeks pregnant fiance walking around here, so you can imagine that might take up some of my time. 🙂

    You can find out if everything works correctly by opening your browser’s DevTools (F12) and going to the ‘network’ tab. When you refresh the page, you’ll see a list of requests. There should be a request to yourdomain.com/collect (if Stealth Mode is enabled) or google-analytics.com/r/collect (if Stealth Mode Lite is disabled).

    That means it’s working. 🙂

    Hope it helps.

    Thread Starter wordgr

    (@wordgr)

    Pregnant women are very difficult at this stage, I know what you mean 🙂
    That with the purchase of the plugin was not meant negatively but my serious!
    I’m trying what you told me !

    Is there also a contact on your site where you can communicate?

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    I didn’t take it as negativity 🙂 it’s just my principle that, although you do get better support after purchase, it shouldn’t be the main reason to purchase something.

    You can contact me at https://woosh.dev/contact

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘analytics no works’ is closed to new replies.