Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » Analytics: You don’t have permission to access /wp-admin/index.php

  • Resolved Leandro Poblet

    (@stoner666)


    I’m getting this when trying to setup my analytics account:
    Forbidden

    You don’t have permission to access /wp-admin/index.php on this server.

    As per @jamesosborne comment in a different post we’re not using WP Rocket plugin

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Hi Leandro,

    Thanks for opening a support topic. The other support topic which you referenced seems to be a separate issue although no worries, lets check what’s occurring. Firstly can you share the information below:

    1. Your Site Health information. You can use this form to share privately if preferred.
    2. Can you share at what stage this occurs during the Analytics setup stage (ie. after clicking on a specific button during the setup stage)?
    3. Have you been able to setup Site Kit with the Analytics module connected on this site previously?

    Let me know if you have any questions on the above.

    Thread Starter Leandro Poblet

    (@stoner666)

    Hi @jamesosborne,

    1. Sent
    2. It happens when I press the button CREATE ACCOUNT
    3. No

    Thank you

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for sharing the additional information. As nothing stands out from initial inspection can you share whether you’re able to select an existing Analytics account as opposed to creating a new one?

    Similar to issues described in this GitHub issue when setting up a new Analytics account there may be something at host level resulting in the error you’re encounter. Alternatively you may have a misconfigured .htaccess file, with the error you’re encountering not specific to Site Kit. I can see there are additional .htaccess rules from checking your Site Health information.

    Let me know anyway if you’re able to select an existing Analytics account.

    Thread Starter Leandro Poblet

    (@stoner666)

    I don’t think it’s related to the GitHub issue you mentioned as there’s no indication of a missing parameter in this case.
    I tried with an existing account and I get the same error.
    I see what you mean about .htaccess file. I’ll remove and re-test to see if I get a different error or success

    Thread Starter Leandro Poblet

    (@stoner666)

    After removing .htaccess I got the same error @jamesosborne

    Plugin Support Abdullah Ramzan

    (@abdullahramzan)

    Hello @stoner666,

    Thanks for the update.

    I didn’t notice any thing wrong in the Site Health information. Can you please answer the following questions:

    1. Did you migrate your site recently before setting up Site Kit?
    2. Which hosting service you are using?
    3. Can you please setup a new site on the same server & try to configure Site Kit?

    Let us know if you are still observing the issue.

    Best Regards,

    Thread Starter Leandro Poblet

    (@stoner666)

    Hi @abdullahramzan,
    1. We didn’t migrate the site, we’re setting it up from scratch.
    2. We’re using https://www.openhost.co.nz/
    3. We cannot do that sorry. Wouldn’t know how to.

    Are there any logs to read or anything else we can do? I mean… setting up a new site isn’t an option really but we really want this resolved.

    Issue is still reproducible.

    Regards

    Plugin Support James Osborne

    (@jamesosborne)

    @stoner666 Many thanks for providing an update. In relation to sharing error logs you can do so if you wish, which we can review. You can use the same form previously used if you wish to share any such log files. Note that setting up a separate WordPress would be great to test the same experience and in many cases hosting providers offer a “Once click install” or “Softaculous” service that makes it a relatively straightforward.

    I don’t think it’s related to the GitHub issue you mentioned as there’s no indication of a missing parameter in this case.

    While not the same error I suspect there may be something at host level resulting in you being unable to create an Analytics account from within Site Kit. In other cases as per this GitHub issue users encounter separate error messages, also when clicking on the “Create account” button.

    Let me know if you have any questions on the above, and of course, totally understand you wish to get it resolved. We’d also love to know what’s occurring with your setup.

    Plugin Support James Osborne

    (@jamesosborne)

    @stoner666 Just to keep you updated we’ve created the below GitHub issue as we investigate this further:
    https://github.com/google/site-kit-wp/issues/3532

    If you could provide the following that would be great as we try to determine the cause:

    1. Any console errors on the final page where you encounter this message (after clicking on the “Create Account” button
    2. Any error logs or confirmation on whether the same occur with a newly created WordPress install (if that’s possible)

    I’ve added some temporary workaround steps to that GitHub issue which you can try in order to proceed. Hopefully this will allow you to get the Analytics module successfully connected. Let me know if you have any questions on this.

    Thread Starter Leandro Poblet

    (@stoner666)

    Hi @jamesosborne,
    The workaround of having it created in Analytics doesn’t work. Same error appears on screen. I’ve been in touch with the hosting provider and there’s no logs as far as they know. When I mentioned it to you I thought there would be logs for the plugin itself somewhere as this has nothing to do with wp or the hosting provider.

    I’ll try and follow up on the GitHub bug in case I can contribute somehow.

    Thank you

    Plugin Support James Osborne

    (@jamesosborne)

    @stoner666 Thanks for the update. I’ll review the suggested workaround after more testing at some stage today and update accordingly, appreciate you checking that.

    From discussions with the team the ModSecurity issue may be triggered from long URL strings. We’re still working on an approach on dealing with this but please do subscribe to the related GitHub issue, while I’ll also keep you updated here with any updates.

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @stoner666 Thank you for your patience here! We’ve identified that this error is occurring due to a recent change in Mod_Security rules. While some hosting providers may be able to adjust these rules, others may not, so we’re going to apply an update in the next Site Kit release (before end of June) to fix this error in the plugin. I’ll update this topic again when the fix has been released.

    Thread Starter Leandro Poblet

    (@stoner666)

    Thank you @shetheliving for the update.
    Looking forward to update the Site Kit version and test the fix myself.

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @stoner666 We’ve implemented a fix for this issue in today’s release of v1.34.1 of Site Kit. Please make sure that your Site Kit plugin is updated and you should be able to successfully set up Analytics now.

    I’ll mark this issue as resolved, but feel free to open a new support topic if you continue to encounter issues, or reopen this topic if you’re still having trouble and we’d be happy to assist. Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.