Support » Plugin: CAOS | Host Google Analytics Locally » analytics.google.com fail

  • Resolved Gaëtan L.

    (@lenglemetz)


    Hi,

    I am updating to 1.93,

    I updated analytics.js, emptied the cache … the script appears on the source code of the pages, but on analytics in real time or audiance, there is nothing that appears!

    So nothing works on all my sites, (with or without cache)

    Can you help me please ?

    Regards,

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Ok,

    Things you should check:

    – Check if the analytics.js file is populated (default path: wp-content/cache/caos-analytics/analytics.js). If not, trigger a manual update by going to Settings > Optimize Analytics > Update analytics.js
    – Are you logged in when checking if the tracking is working? The default setting is to NOT track logged in Administrators. This behavior can be changed within the settings screen.
    – Are you trying to check tracking from within a Private/Incognito window of your browser? If so, make sure that ‘Tracking Protection’ isn’t enabled. Many modern browser (chrome, firefox, edge) have this enabled by default.

    If after this you’re still running into issues. Let me know.

    Also, next time, add the url you need help with. I could’ve ruled out the first suggestion for you, if you did.

    Hi,

    I do not pass the first step, in my sites with or without cache, I have nothing on wp-content/cache/caos-analytics/analytics.js, when I click on the update or save button, it does not generate a file (there is no problem for server rights)

    I am under chrome, I only do tests in private browsing 😉

    Exemple url : https://www.artisbois.fr (the code is present…)

    • This reply was modified 1 year, 4 months ago by Gaëtan L..
    • This reply was modified 1 year, 4 months ago by Gaëtan L..

    Same issue. I just updated CAOS 2 hours ago. Even updated the analytics.js at the same time to prevent any issues. Now, I just ran GA and was surprised. There’s nothing in GA since the past 2 hours.

    Update: Cleared website cache and that of CF as well. Then used the ‘Update analytics.js’ option again. It seems to be fine now.

    after several tests, there is a problem with creating the cache folder and the caos-analytics folder. Once in place (manually added folder), I can generate the analytics.js file!

    I doubt that it is a problem of the right of the files, because I can easily install a plugin via my sites, clean the caches etc without any problem. You just have to know that the site is under a mutualised (but I have no restriction on the files).

    We will see with the times if other people are affected 🙂

    Have a nice week end !

    Hi,

    I confirm, version 1.94 solves the problem. But, I have another problem, I open a new topic 😉

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    I added a fix for the directory creation bug. So I’m happy it worked out for you! It’s a shame you’re getting another error now, though. I’m waiting for your ticket! 🙁

    Gulshan Kumar

    (@thegulshankumar)

    Just a suggestion,
    If js require update, why not integrate CAOS with Cloudflare API and trigger purge by URL automatically when required.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘analytics.google.com fail’ is closed to new replies.