Support » Plugin: WooCommerce Google Analytics Integration » Analytics do not work when Universal Analytics is enabled

  • Resolved henrikdamdk

    (@henrikdamdk)


    Hi,

    I have been trying without luck to get the Google Analytics to work on our site. It works when Universal Analytics is not enabled. But that would then mean we cannot track ecommerce.

    Can you see what’s wrong? Thanks!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter henrikdamdk

    (@henrikdamdk)

    Update: After a while, it seemed regular tracking was working to some extent. But not tracking all users. It also showed an error in the Tag Assistant Chrome plugin.

    So now I additionally added the regular tracking script manually in the head.

    I hope someone can still help to get the tracking to work properly?

    Plugin Support John Coy a11n

    (@johndcoy)

    Automattic Happiness Engineer

    Hi @henrikdamdk

    I was able to use the Google Tag Assistant extension for Google Chrome to see the tag ID has been added correctly and no errors.

    The plugin omits admins from tracking so if you’re testing, make sure to use an incognito window and a user account that isn’t assigned to the administrator role.

    There are a few settings to enable within Google Analytics as shown in the below documentation. Once those steps have been achieved, wait a few hours ( 24 hours for best results ) and data should show as expected:

    https://docs.woocommerce.com/document/google-analytics-integration/

    Hope that helps,

    Thread Starter henrikdamdk

    (@henrikdamdk)

    Thanks so much @johndcoy!

    I now disabled the manually inserted tracking script, so that it is now only the Google Analytics Integration that servers the script.

    And everything is set up according to the guide.

    When using the Google Tag Assistant I’m seeing an error “No HTTP response detected” as seen below. I guess that is not expected?

    https://prnt.sc/r9421c

    • This reply was modified 1 year, 3 months ago by henrikdamdk.
    Plugin Support John Coy a11n

    (@johndcoy)

    Automattic Happiness Engineer

    Hi @henrikdamdk

    Could you add the ID to a staging site with only the Twenty Twenty theme active and disabling all plugins except for WooCommerce and Google Analytics to see if this resolves the issue?

    Thread Starter henrikdamdk

    (@henrikdamdk)

    Thanks @johndcoy, but unfortunately that didn’t work.

    I disabled all plugins except Woocommerce and Google Analytics and using TwentyTwenty theme, but it’s unfortunately not tracking and still giving the “No HTTP response detected” error from the Google Tag Assistant.

    What could it be then?

    I’m watching this too. I want the same setup so maybe I can contribute. I just enabled the Universal setting and will see what changes occur.

    Thread Starter henrikdamdk

    (@henrikdamdk)

    In the meantime without changing anything – it started working. And Google Tag Assistant is no longer returning the error.

    Not sure what happened – but now it works perfectly 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Analytics do not work when Universal Analytics is enabled’ is closed to new replies.