Support » Plugin: WP-Optimize - Clean, Compress, Cache. » An unexpected response was received.

  • Resolved shirtguy72


    Just updated to 3.0.0 I have not made changes of any kind, have not set caching. I was just having a look around in settings. Now whenever I start moving around in WP Optimize a small warning box appears basically saying “my website url says … An unexpected response was received.”

Viewing 15 replies - 1 through 15 (of 20 total)
  • Could this possibly have anything to do with this (from WP Optimize) “It looks like you already have an active caching plugin (WP Fastest Cache) installed. Having more than one active page cache might cause unexpected results.” ?

    Now trying to “Clear all trashed post” error label keeps popping up and action to clear trashed post not working.

    I have the same problem immediately after updating.

    (edited to flag for follow-up replies via email).

    • This reply was modified 10 months, 1 week ago by cgscomputers.

    Same here, after updating the plugin says all the time: Unexpected answer and doesn´t let clean any options.

    Please review it asap.


    Just a note from here at WP-Optimize to say we’re reviewing and will update this thread shortly.

    Thanks you for the quickness. We can´t be with the service that your plugin gives us 🙂

    Hi @ibiza69, @shirtguy72, @cgscomputers (and anyone else who might be experiencing this issue),

    I’ve been working on this with some of the team here and we’re trying to replicate the problem, including any potential issues with having an existing caching plugin installed, and then installing the latest WP-Optimize version.

    So far I haven’t been able to replicate the issue, and the new WP-Optimize version is working harmoniously with existing cache plugins. There is a warning (the one that @shirtguy72 mentioned above) that explains there could be unexpected results if the new WP-Optimize caching is enabled whilst using other caching plugins, and if I manually turn that caching on, there are issues (as expected).

    Could any of you give us some more info on your setup and environment? If you’re on the latest version of WordPress, the easiest way would be to use the WordPress “Site Health Info” page and to click “Copy site info to clipboard”, then paste that here (or in a pastebin etc). That page is found under Tools > Site Health > Info (tab).

    The errors and messages you’ve mentioned relate to requests from WP-Optimize to get information from the underlying server, so the issue looks like it could be specific to your setups. The more information we have, the more chance we have of replicating the issue and releasing a fix, or at the very least offering a solution!

    In the meantime we’ll keep looking into this.


    Plugin Author David Anderson


    Also – when you get this error, please open your JavaScript console and send a screenshot (e.g. use of what is logged there. Here’s how to open your JavaScript console:


    Here’s the screen grab you asked for – it takes about 5 – 10 seconds before the alert pops up. The section of text in the console that begins with ReferenceError is the output at that time.

    I’ve never enabled the new caching options on the plugin. Also, I’ve tried disabling my existing caching plugin & clearing the cache to no affect. Also disabled all my plugins etc… no dice.


    I’m using 2 different shared hosting accounts – so I don’t have much control over the servers. I use one for all of my production sites and one for their development twins. I have many sites so I haven’t had time to test them all, but in general it seems only the sites on the production account are throwing this error. So, I agree that the response has something to do with the specific setup & probably has nothing to do with themes/plugins.

    Both shared hosting servers have similar set ups – there is a difference in the OS version but that’s about it. As far as modules & PHP versions, everything between the two is identical.

    There’s one twist though – when I first discovered this issue, I looked at one of my development sites and it was throwing the error as well. But 8 hours later, the error is not throwing any longer – and I’ve made no changes. Caveat: I was wildly flipping back and forth between production/dev quite a bit trying to figure out what was going on so I suppose there’s a chance I looked at the production site by accident, but I’m pretty sure that’s not the case. At this time however it seems only the sites on my production setup are throwing the error, I can’t find any instance on my development setup where this is occurring.

    As far as site health info, that is a lot of information disclosure to post in a public forum – is there a way you can accept the information privately?

    Hi David, thanks a lot for the time and dedication, we have created this for you, hopefully works and gives you a clue where problem might come from.

    ERROR WE SEE AT PLUGIN OPTIMIZE (that message jumps when you try to make an optimization and the job never finishes, keeps on loop):



    ### wp-core ###

    version: 5.2.2
    site_language: en_GB
    user_language: en_GB
    permalink: /%category%/%postname%/
    https_status: true
    user_registration: 1
    default_comment_status: open
    multisite: false
    user_count: 38
    dotorg_communication: true

    ### wp-paths-sizes ###

    wordpress_path: /home/XXXXXXXXXXXX/public_html
    wordpress_size: 53.28 MB (55865356 bytes)
    uploads_path: /home/XXXXXXXXXXXX/public_html/wp-content/uploads
    uploads_size: 252.73 MB (265008706 bytes)
    themes_path: /home/XXXXXXXXXXXX/public_html/wp-content/themes
    themes_size: 11.70 MB (12267608 bytes)
    plugins_path: /home/XXXXXXXXXXXX/public_html/wp-content/plugins
    plugins_size: 101.02 MB (105928458 bytes)
    database_size: 13.66 MB (14321411 bytes)
    total_size: 432.39 MB (453391539 bytes)

    ### wp-dropins (1) ###

    advanced-cache.php: true

    ### wp-active-theme ###

    name: FlexSqueeze II Child Theme
    version: 1.0
    author: Anonymous
    author_website: (undefined)
    parent_theme: FlexSqueeze II
    theme_features: woocommerce, editor-style, nav-menus, post-thumbnails, automatic-feed-links, widgets, menus
    theme_path: /home/XXXXXXXXXXXX/public_html/wp-content/themes/flexsqueeze2

    ### wp-themes (1) ###

    FlexSqueeze II: version: 1.1.0, author: Advantus Media, Inc.

    ### wp-mu-plugins (1) ###

    BPS MU Tools: version: 4.0, author: AITpro

    ### wp-plugins-active (37) ###

    404 to 301 – Redirect, Log and Notify 404 Errors: version: 3.0.5, author: Joel James
    AccessPress Facebook Auto Post: version: 2.0.2, author: AccessPress Themes (latest version: 2.0.4)
    All In One SEO Pack: version: 3.1.1, author: Michael Torbert
    AMP: version: 1.2.0, author: AMP Project Contributors
    BulletProof Security: version: 3.5, author: AITpro Website Security
    Contact Form 7: version: 5.1.3, author: Takayuki Miyoshi
    Cookie Bar: version: 1.8.6, author: Brontobytes
    Forget About Shortcode Buttons: version: 2.1.2, author: Designs & Code
    Head & Footer Code: version:, author: Aleksandar Urosevic
    Heartbeat Control by WP Rocket: version: 1.2.5, author: WP Rocket
    iThemes Security: version: 7.4.0, author: iThemes
    Jetpack by version: 7.5.3, author: Automattic
    Loco Translate: version: 2.3.0, author: Tim Whitlock
    Logo Showcase with Slick Slider: version: 1.1, author: InfornWeb
    OneSignal Push Notifications: version: 1.17.5, author: OneSignal
    Rich Text Excerpts: version: 1.3.4, author: Peter Edwards <>
    Simple Social Icons: version: 3.0.1, author: StudioPress
    Smart Slider 3: version: 3.3.21, author: Nextend
    Super Socializer: version: 7.12.30, author: Team Heateor
    Tag Pages: version: 1.0.2, author: Bjorn Wijers <burobjorn at burobjorn dot nl>
    TinyMCE Advanced: version: 5.2.1, author: Andrew Ozz
    Ultimate Member: version: 2.0.53, author: Ultimate Member
    Ultimate Member – Profile Tabs: version: 2.1.1, author: PlusPlugins
    Wordfence Security: version: 7.3.5, author: Wordfence
    WordPress Protection Lite: version: 8, author:
    WP-Optimize – Clean, Compress, Cache: version: 3.0.1, author: David Anderson, Ruhani Rabin, Team Updraft
    WP Change Default From Email: version: 1.1.1, author: Subodh Ghulaxe
    WP Job Manager: version: 1.31.3, author: Automattic (latest version: 1.33.3)
    WP to LinkedIn Auto Publish: version: 1.5, author:
    WP Twitter Auto Publish: version: 1.4, author:
    X-Scroll To Top – Responsive: version: 2.0.2, author: Md. Jahidul Islam
    XT Easy Google Adsense Injection: version: v1.0, author: Xt-Themes

    ### wp-plugins-inactive (2) ###

    Easy Theme and Plugin Upgrades: version: 2.0.1, author: Chris Jean
    Maintenance Mode Page: version: 1.6.3, author: wpshopmart

    ### wp-media ###

    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1684
    imagemagick_version: ImageMagick 6.9.4-10 Q16 x86_64 2017-11-14
    imagick::RESOURCETYPE_AREA: 126 GB
    imagick::RESOURCETYPE_DISK: -1
    imagick::RESOURCETYPE_FILE: 12288
    imagick::RESOURCETYPE_MAP: 126 GB
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.70

    ### wp-server ###

    server_architecture: Linux 2.6.32-773.26.1.lve1.4.35.el6.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.3.6 64bit
    php_sapi: litespeed
    max_input_variables: 1000
    time_limit: 1500
    memory_limit: 512M
    max_input_time: -1
    upload_max_size: 256M
    php_post_max_size: 128M
    curl_version: 7.62.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: true

    ### wp-database ###

    extension: mysqli
    server_version: 5.6.44-cll-lve
    client_version: mysqlnd 5.0.12-dev – 20150407 – $Id: XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX $

    ### wp-constants ###

    WP_HOME: https://XXXXX.COM
    WP_CONTENT_DIR: /home/XXXXXXXXXXXX/public_html/wp-content
    WP_PLUGIN_DIR: /home/XXXXXXXXXXXX/public_html/wp-content/plugins
    WP_DEBUG: false
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined

    ### wp-filesystem ###

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable

    ### jetpack ###

    site_id: 93789883
    ssl_cert: No
    time_diff: 2
    version_option: 7.5.3:1563430791
    old_version: 7.5.2:1562307694
    public: Public
    tokens_set: Blog User
    version: 7.5.3
    jp_plugin_dir: /home/XXXXXXXXXXXX/public_html/wp-content/plugins/jetpack/
    plan: free
    SERVER_PORT: 443
    HTTPS: on
    protect_header: {“trusted_header”:”REMOTE_ADDR”,”segments”:1,”reverse”:false}
    full_sync: {“started”:”Fri, 29 Mar 2019 18:05:09 +0000″,”queue_finished”:”Fri, 29 Mar 2019 18:05:09 +0000″,”send_started”:”Fri, 29 Mar 2019 18:05:16 +0000″,”finished”:”Fri, 29 Mar 2019 18:05:16 +0000″,”sent”:{“constants”:1,”functions”:1,”options”:1,”users”:1},”sent_total”:[],”queue”:{“constants”:1,”functions”:1,”options”:1,”users”:1},”config”:{“options”:true,”functions”:true,”constants”:true,”users”:[2]},”total”:{“constants”:1,”functions”:1,”options”:1,”users”:1}}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {“home”:”https:\/\/XXXX.COM”,”siteurl”:”https:\/\/XXXX.COM”,”WP_HOME”:”https:\/\/XXXX.COM”,”WP_SITEURL”:”https:\/\/XXXX.COM”}
    idc_error_option: false
    idc_optin: true
    cxn_tests: All Pass.

    Oh, forgot, don´t know if in wp site health says or not, but we use:

    PHP 7.3

    And “do not have” any CACHE PLUGIN plugin installed 🙂 All broke our menus at the sites, so we don´t use them anymore.

    Cheers and hopefully we have great news from you very soon 😉

    Plugin Author David Anderson


    Thank you. We’re getting close now. I can see what the problem is, but not exactly how it is caused. If you use “View Source” in your web browser to view the HTML source, and search for all scripts with wp-optimize/js/ in them, what exactly are the URLs for the scripts (in the script tag) ? I have a couple of suspicions.


    Plugin Author David Anderson


    It’s Friday evening, and rather than risk other people having the same problem over the weekend, we’ve made a 3.0.2 release that may fix it, or may not. If it doesn’t, please see if you can send the information requested in my immediately preceding post.

    David Anderson / Team Upddraft & EVERY ONE of my WP Brothers and Sisters who helped … Thanks for the quick response and true effort to remedy the issue … I first deleted “advanced-cache.php” from my c-panel then logged into my site and ADD NEW WPO version 3.0.2 ALL seems to be well. Again thanks to ALL !!!

    • This reply was modified 10 months, 1 week ago by shirtguy72.

    Hi David! Please accept my apologies, I was in a meeting and could read your answer.

    Here are all details you asked for:

    <script type=’text/javascript’ src=’’></script&gt;

    <script type=’text/javascript’ src=’’></script&gt;

    <script type=’text/javascript’ src=’’></script&gt;

    <script type=’text/javascript’>
    /* <![CDATA[ */
    var wpoptimize = {“automatic_backup_before_optimizations”:”Automatic backup before optimizations”,”error_unexpected_response”:”An unexpected response was received.”,”optimization_complete”:”Optimisation complete”,”run_optimizations”:”Run optimizations”,”cancel”:”Cancel”,”enable”:”Enable”,”disable”:”Disable”,”please_select_settings_file”:”Please, select settings file.”,”are_you_sure_you_want_to_remove_logging_destination”:”Are you sure you want to remove this logging destination?”,”fill_all_settings_fields”:”Before saving, you need to complete the currently incomplete settings (or remove them).”,”table_was_not_repaired”:”%s was not repaired. For more details, please check the logs (configured in your logging destinations settings).”,”are_you_sure_you_want_to_remove_this_table”:”Are you sure you want to remove this table?”,”table_was_not_deleted”:”%s was not deleted. For more details, please check your logs configured in logging destinations settings.”,”please_use_positive_integers”:”Please use positive integers.”,”please_use_valid_values”:”Please use valid values.”,”update”:”Update”,”run_now”:”Run now”,”starting_preload”:”Started preload…”,”loading_urls”:”Loading URLs…”,”current_cache_size”:”Current cache size:”,”number_of_files”:”Number of files:”,”spinner_src”:”https:\/\/\/wp-admin\/images\/spinner-2x.gif”,”sites”:[],”loggers_classes_info”:{“updraft_php_logger”:{“description”:”Log events into the PHP error log”,”available”:true,”allow_multiple”:false,”options”:[]},”updraft_email_logger”:{“description”:”Log events to email”,”available”:true,”allow_multiple”:true,”options”:{“emails”:[“Enter email for logs here”,”email”]}},”updraft_ring_logger”:{“description”:”Store the most recent log entries in the WordPress database”,”available”:true,”allow_multiple”:false,”options”:{“ring_logger_limit”:”How many last records store?”}}}};
    /* ]]> */

    <script type=’text/javascript’ src=’’></script&gt;

    <script type=’text/javascript’ src=’’></script&gt;

    <script type=’text/javascript’ src=’’></script&gt;

    <script type=’text/javascript’ src=’’></script&gt;

    <script type=’text/javascript’ src=’’></script&gt;

    Thanks! Hopefully this information helps 😉

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘An unexpected response was received.’ is closed to new replies.