An Unexpected HTTP Error occurred during the API request on WordPress 3.3.1 (4 posts)

  1. aquapan
    Posted 4 years ago #

    Curious thing happened. Plugins went weird and then my install was throwing server error 500's so I went through and one by one checked all the plugins to determine if it was them. Found about 10 that were strange and causing 500 errors so i left them off and deleted their code in case it was the issue. The site seems to work fine. Now however upon attempting to re-install the plugins again from fresh downloads I get the error "An Unexpected HTTP Error occurred during the API request".

    I followed another thread on here attempting to get a solution using core control plugin and it didn't help me.

    I note when in Core Control in Manage Transports (I have activated External Http Access) I see errors for all http transports:

    cURL throws = An Error has occured: Couldn't resolve host 'tools.dd32.id.au'

    php streams throws = An Error has occured: Could not open handle for fopen() to http://tools.dd32.id.au/wordpress/core-control.php

    php fsockopen throws = An Error has occured: 0: php_network_getaddresses: getaddrinfo failed: Name or service not known

    So that leaves me completely stuck as to what to do to make this work again.

    I hope someone knows as this install was only working yesterday completely fine.


  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  3. aquapan
    Posted 4 years ago #

    Thanks Esmi

    I renamed the plugins folder and my site worked fine instantly.

    No doing a test of each one by one till I see a break.


  4. nickaps
    Posted 4 years ago #

    having same problem
    no plugins installed, cant import data, help
    i beg, please.

Topic Closed

This topic has been closed to new replies.

About this Topic