Support » Fixing WordPress » An unexpected error occurred when trying to search for plugins

  • Resolved andy.newby

    (@andynewby)



    Hi,

    I’ve got a vanilla WP install that I’ve set up, and its working for the most of it. However, I just went to try and install some plugins, and got an error when trying to search:

    An unexpected error occurred. Something may be wrong with WordPress.org or this serverโ€™s configuration. If you continue to have problems, please try the support forums

    I’ve done some research, and people were suggested to check if curl was available in PHP, and it is (with a phpinfo());

    Additional .ini files parsed /etc/php5/cgi/conf.d/05-opcache.ini, /etc/php5/cgi/conf.d/10-pdo.ini, /etc/php5/cgi/conf.d/20-curl.ini, /etc/php5/cgi/conf.d/20-json.ini, /etc/php5/cgi/conf.d/20-mysql.ini, /etc/php5/cgi/conf.d/20-mysqli.ini, /etc/php5/cgi/conf.d/20-pdo_mysql.ini, /etc/php5/cgi/conf.d/20-readline.ini, /etc/php5/cgi/conf.d/20-ssh2.ini

    curl
    cURL support enabled
    cURL Information 7.38.0

    I already have the following setup in my wp-config.php (otherwise it kept asking me to log in to FTP every time I wanted to do anything);

    define('FS_METHOD', 'direct');
    define('FTP_BASE', '/srv/www/xx/www/blog/');
    define('FTP_CONTENT_DIR', '/srv/www/xx/www/blog/wp-content/');
    define('FTP_PLUGIN_DIR ', '/srv/www/xx/www/blog/wp-content/plugins/');
    define('FTP_USER', 'the-user');
    define('FTP_PASS', 'my password
    define('FTP_HOST', 'xx.net');

    I’m at a bit of a dead end as to what to try next. Any suggestions? ๐Ÿ™‚

    Thanks

    Andy

Viewing 3 replies - 1 through 3 (of 3 total)
  • The FTP is used when set in the WP Config file AND/OR the folder permissions of the WordPress install. I find this page very useful – WordPress Permissions Update

    As far as not being able to search, that is strange – have you tried with a new copy of WordPress to see if it has to do with your install?

    Only other things that I can think of is your website not being able to search for plugins due to a network setting.

    99% of the time there is a configuration error on the server. The most current version of cURL is 7.50.3 and WordPress requires PHP 5.6 or greater. https://wordpress.org/about/requirements/

    You shouldn’t have to have all the “define” in the config.sys. If you do it is because of some configuration error. Under settings/general what do you have to the name and location of WP?

    Hi,

    Sorry, it’s been a manic week so I’ve only just got back to this (it’s only a personal project)

    OK, so it sounds more like a server issue – so maybe I need to look into that.

    PHP wise, I’m running:

     php --version
    PHP 5.6.24-0+deb8u1 (cli) (built: Jul 26 2016 08:17:07)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
        with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

    Curl looks fine:

    curl --version
    curl 7.38.0 (x86_64-pc-linux-gnu) libcurl/7.38.0 OpenSSL/1.0.2d zlib/1.2.8 libidn/1.29 libssh2/1.4.3 librtmp/2.3
    Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp scp sftp smtp smtps telnet tftp
    Features: AsynchDNS IDN IPv6 Largefile GSS-API SPNEGO NTLM NTLM_WB SSL libz TLS-SRP

    PHP seems to be correctly running as nginx:

    ps aux | grep "php"
    nginx     3301  0.0  0.6 332344 25668 ?        Ss   06:12   0:00 /usr/bin/php5-cgi
    nginx     3362  0.2  1.7 343948 69964 ?        S    06:12   0:04 /usr/bin/php5-cgi
    nginx     3363  0.2  2.1 343556 85752 ?        S    06:12   0:05 /usr/bin/php5-cgi
    nginx     3364  0.2  1.7 342884 69704 ?        S    06:12   0:04 /usr/bin/php5-cgi
    nginx     3365  0.2  1.8 343764 73676 ?        S    06:12   0:04 /usr/bin/php5-cgi
    nginx     3366  0.3  2.1 344236 85476 ?        S    06:12   0:05 /usr/bin/php5-cgi
    nginx     3367  0.2  1.8 343020 73840 ?        S    06:12   0:05 /usr/bin/php5-cgi
    root      3473  0.0  0.6 340948 26392 ?        Ss   06:12   0:00 php-fpm: master process (/etc/php5/fpm/php-fpm.conf)
    www-data  3686  0.0  0.2 340948  8568 ?        S    06:12   0:00 php-fpm: pool www
    www-data  3687  0.0  0.2 340948  8572 ?        S    06:12   0:00 php-fpm: pool www
    root      5159  0.0  0.0  12744   912 pts/0    S+   06:41   0:00 grep php

    The server is using nginx.

    File permissions are www-data:www-data

    After seeing that, I thought I’d just give it a whirl of changing to nginx:nginx, and that seems to have done it ๐Ÿ™‚ I no longer need extra FTP config setup, and the rest of the install seems to be behaving as well.

    Thanks for your replies ๐Ÿ™‚

    Andy

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘An unexpected error occurred when trying to search for plugins’ is closed to new replies.