WordPress.org

Ready to get started?Download WordPress

Forums

An unexpected error occurred. Something may be wrong with WordPress.org or this (11 posts)

  1. dwhswebhosting
    Member
    Posted 1 year ago #

    I run a dedicated server and seem to have this issue server wide, first Akismet will not save the key when I enter and save it. As if the mysql is not updating.

    It just says this over and over:

    Akismet is almost ready. You must enter your Akismet API key for it to work.

    The main problem is trying to add a plug in I get this error:

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

    I have disabled the firewall but still get the error.

    I assume it's something in the way it resolves domains through php?

    The site is http://www.ecommerce-web-hosting.com

  2. Yui
    Member
    Posted 1 year ago #

    does

    nslookup rest.akismet.com
    or
    host rest.akismet.com

    work from command line?

    $ host rest.akismet.com
    rest.akismet.com has address 66.135.58.61
    rest.akismet.com has address 66.135.58.62
    rest.akismet.com has address 72.233.69.88
    rest.akismet.com has address 72.233.69.89

    You can check server status in akismet settings as well
    and there is a link to their status page

    You can try traceroute rest.akismet.com from yourserver too in case of network problems

  3. dwhswebhosting
    Member
    Posted 1 year ago #

    root@dwhs25 [~]# nslookup rest.akismet.com
    Server: 66.249.137.215
    Address: 66.249.137.215#53

    Non-authoritative answer:
    Name: rest.akismet.com
    Address: 72.233.69.89
    Name: rest.akismet.com
    Address: 66.135.58.61
    Name: rest.akismet.com
    Address: 66.135.58.62
    Name: rest.akismet.com
    Address: 72.233.69.88

    Also now the akismet is working but the plug ins still give the same error:

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

  4. Yui
    Member
    Posted 1 year ago #

    does YOURSITE/wp-admin/admin.php?page=akismet-key-config
    show that
    Akismet server Network Status
    66.135.58.61 Accessible
    66.135.58.62 Accessible
    72.233.69.89 Accessible
    72.233.69.88 Accessible

    and API key is correct?

    Can your WP installation make remote HTTP requests? I.e. check for plugin/theme updates?

    PHP curl extension is enabled?

  5. dwhswebhosting
    Member
    Posted 1 year ago #

    Akismet server Network Status
    66.135.58.62 Accessible
    66.135.58.61 Accessible
    72.233.69.89 Accessible
    72.233.69.88 Accessible

    Yes that works, but no the theme will now show updates or search for new ones.

    I don't think my WP can make http requests.

    php curl is enabled but may be broke, do you know a way I can test it?

    I also show this error:

    [error] [client 76.167.142.80] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/ecommerc/public_html/index.php, referer: http://www.ecommerce-web-hosting.com/wp-admin/admin.php?page=akismet-key-config
    [Tue Jun 11 16:07:00 2013]

    Also here is the php info page:
    http://www.ecommerce-web-hosting.com/info.php

  6. Yui
    Member
    Posted 1 year ago #

    >php curl is enabled but may be broke, do you know a way I can test it?

    its enabled and works, by showing all 4 akismet servers acessible PHP has made a request to each server ( /verify-key ) and got a response

    You have suhosin, sometimes it can be paranoid, try temporarely put it into simulation mode or disable and check if your problems will be gone.

    And your suphp error, i cant tell anything , cos i never used suphp, but its better to check too why it cannot fork a child process

  7. dwhswebhosting
    Member
    Posted 1 year ago #

    I found it!

    Strange I disabled the firewall and even shut down iptables but it wasn't until I added the WordPress API IP: 72.233.56.139 that is connected right away.

    Still a mystery how WP got blocked but now I know next time.

    Thanks so much for the help!

    SOLVED

  8. ac100
    Member
    Posted 1 year ago #

    Hi ..I faced the same issue and here's my solution:

    1) Run virus scan through C-panel and found an add-on domain infected, as I had installed a torrent-downloaded premium theme into it.

    2) Removed the add-on, cleared the sub-directory, and scanned again.

    3) Asked the hosting provider to unblock port 80.

    NOTE: Most of the hosting providers automatically block port 80, when they find any malicious file in auto-scans. so write them to unblock it.

  9. WPyogi
    Forum Moderator
    Posted 1 year ago #

    @ac100 - it's great you want to help out here, but please don't repeatedly post this same solution in multiple threads when they are already solved.

  10. Akash Ch Gupta
    Member
    Posted 1 year ago #

    @dwhswebhosting were to add *WordPress API IP: 72.233.56.139*, I am also having same problem.

  11. dwhswebhosting
    Member
    Posted 1 year ago #

    @Akash Ch Gupta you need to add this at the server level.

    I would contact your hosting company and ask them to whitelist: 72.233.56.139

Topic Closed

This topic has been closed to new replies.

About this Topic