Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » An unexpected error occured. This is most likely due to a server misconfiguratio

  • Resolved josch87

    (@josch87)


    I get the following message when trying to upload an image.

    An unexpected error occured. This is most likely due to a server misconfiguration. Check your PHP error log or ask your hosting provider for assistance.

    WordPress 5.1.1
    NextGEN Gallery 3.1.17
    Hoster: Strato

    Betriebssystem : SunOS (32 Bit)
    Server : Apache/2.4.39 (Unix)
    Speicherverbrauch : 8.71 MByte
    MySQL Version : 5.6.42-log
    SQL Modus : NO_ENGINE_SUBSTITUTION
    PHP Version : 7.1.28
    PHP Safe Mode : Aus
    PHP Allow URL fopen : An
    PHP Memory Limit : 256
    PHP Max Upload Größe : 64M
    PHP Max Post Größe : 76M
    PCRE Backtracking Limit : 1000000
    PHP Max Script Execute Time : 120s
    PHP Exif Modul : Ja (V7.1.)
    PHP IPTC Modul : Ja
    PHP XML Modul : Ja

    Nothing about NextGEN in debug.log or hosters error logs.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @josch87,

    Let’s first check the server settings to make sure you have everything up to date. Reach out to your hosting provider and confirm they have the https://www.imagely.com/docs/requirements/ settings in place:

    With those in place, everything should work smoothly for you. If the issue still shows up, let’s check to see if there is a plugin conflict happening. Temporarily deactivate all plugins, then reactivate NextGEN Gallery only. Does the issue still appear? If so, temporarily switch to a WordPress default theme (this deactivation is only intended to quickly check to see if the issue goes away or is still present). If by deactivating the other plugins the issue does go away, reactivate each of the other plugins one at a time to locate the culprit. Keep me posted on your results 🙂

    Mihai

    josch87

    (@josch87)

    Thank you very much for your feedback.

    I checked my webspace for the following:

    • PHP: Upgradet to PHP Version 7.2.17 / error still occures)
    • memory_limit: 256M
    • upload_max_filesize: 64M
    • post_max_size: 76M
    • Folder “wp-content” chmod 755
    • Files in “wp-content” chmod 644
    • GD Support: enabled
    • GD Version: bundled (2.1.0 compatible)
    • Already deactivated all plugins and try running with Twenty Nineteen.

      Thank you very much.

    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @josch87,

    Can you please access “Gallery -> Add Gallery / Images” try to add some picture and check the browser’s console to see if there are any errors there.

    Mihai

    josch87

    (@josch87)

    VM393:1 Uncaught SyntaxError: Unexpected token < in JSON at position 0
    at JSON.parse (<anonymous>)
    at Object.success (jquery.filetree.js?ver=3.1.17:57)
    at i (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.1.1:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.1.1:2)
    at y (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.1.1:4)
    at XMLHttpRequest.c (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.1.1:4)

    • This reply was modified 3 months ago by  josch87.
    Plugin Support mihai-imagely

    (@mihaiimagely)

    Thanks for your quick reply.
    Can you please access “Dashboard -> Updates” and reinstall WordPress from there then try to upload any image to NextGen again?

    josch87

    (@josch87)

    I reinstalled and I tested with 4.9.x and 5.1.x, same behaviour.

    Plugin Support mihai-imagely

    (@mihaiimagely)

    Oh, well. Thanks for trying this. In such a case it is most likely that the server’s ModSec or firewally blocks the “?photocrati_ajax=1&action=upload_image” request that NextGen uses for uploading the images to a gallery.

    Please contact the hosting provider and ask them to make sure that they aren’t blocking this request “?photocrati_ajax=1&action=upload_image” then ask them if it would be possible to temporarily deactivate ModSec and test the upload again.

    josch87

    (@josch87)

    Hoster is not aware of any blocker and recommends deleting browser cache and deinstalling and installing plugin again. Also we deactivated a serverside filter for the guest book.

    Nothing works but I keep in touch with the hoster. Do you have any other recommendations?

    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @josch87,

    You might need to reset NextGen Gallery Settings.
    At this moment we have an update in our plugin, and it will be released soon.
    We can provide a beta copy for you.

    Please send us a bug report here: http://www.imagely.com/report-bug, refer back to this forum thread and let them know Gaby referred you.

    Note: do not forget to include this forum link

    • Reseting all options
    • Deleting and reinstalling plugin
    • Reinstalling same WordPress version

    did not work. Also

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);

    did not give out any php errors concerning this problem.

    I already created a bug report on your website (ticket 280235) and they forwarded me to this forum. I will open this ticket again.

    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @josch87,

    Can you please ask them to temporarily deactivate the ModSec so you could test uploading with it disabled?

    ModSec is not part of the hosting and therefore not active. I sent you a php info so that you can see the current settings and a site health report after updating to WP 5.2 today.

    • This reply was modified 2 months, 1 week ago by  josch87.
    Plugin Support gabyimagely

    (@gabyimagely)

    Hello @josch87

    According to the existing bug report in our ticket platform, we are waiting for some feedback from you. Could you please check your ticket?

    Many thanks!

    Plugin Support gabyimagely

    (@gabyimagely)

    We are sharing the solution with the rest of the WordPress community.
    Thank you so much @josch87!

    We found that this particular site had an index.htm that was interfering with the normal functioning of NextGen gallery, the solution is to rename that splash or landing page “index.htm” with something like “_index.htm”.

    Our developers are already aware about this situation and they will include a path in future releases.

    Again, many thanks!

    Thank you very much!

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.