Support » Plugin: Modern Footnotes » An option to use normal text as shortcode

  • I love this plugin, it’s so far the best I’ve found.
    It has, however, some issues with Gutenberg (or, to be more precise, it’s Gutenberg that has problems with it):

    I’ve chosen [footnote] as my personal shotcode, basically because it was the same of the plugin I used previously and it’s easy to remember.

    But, when I add it to a Gutenberg paragraph, it gets recognized as a shorcode and put on a block on it’s own. This means having it on a new line.

    Example:

    Hello[footnote]Hi![/footnote], how are you?

    It ends up as:

    Hello
    (1)
    , how are you?

    Doing some experimenting (like writing the shortcode after adding internal text) sometimes I can trick Gutenberg not to recognize it as a shortcode.

    So my suggestion is to use a more “standard” text as option like (I’ve saw it in another plugin and I think it’s perfect) a double parenthesis:

    Hello((Hi!)), how are you?

    This way it’s super easy to remember and Gutenberg won’t nag you trying to convert it. Do you think it’s a viable option?

    Thanks.

    • This topic was modified 1 year, 4 months ago by locksoft.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Update: I understand this method could potentially interfere with the “referencenumber” attribute.
    What about something like this:

    ((5 … ))

    The first number after the double parenthesis would be the reference number.

    Plugin Author prismtechstudios

    (@prismtechstudios)

    Hi @locksoft,

    Thanks for letting me know about this. I’ve been trying but I haven’t been able to reproduce this in Gutenberg. Would you be able to take a screenshot of what you’re seeing in Gutenberg when this issue is happening?

    Cheers,
    Sean

    Sure, here’s a couple of screenshots:

    https://postimg.cc/WFF2185J
    https://postimg.cc/zyGYfpBX

    (some typos in the screenshot, “test” should be “text”; english is not my main language)

    • This reply was modified 1 year, 4 months ago by locksoft.
    • This reply was modified 1 year, 4 months ago by locksoft. Reason: It seems I can't post direct images here, so I paste the links
    • This reply was modified 1 year, 4 months ago by locksoft.

    Also, I’d like to report a small issue on the topbar button (I discovered it just today). If you select some text that has tags, the footnote gets cut in multiple buttons.

    Example:

    Hi, I'm an <em>highlighted</em> footnote

    If I select it all and press the button I get:

    <mfn>Hi, I'm an </mfn><em><mfn>highlighted</mfn></em><mfn> footnote</mfn>

    Another bug:

    The plugin perfectly works in all my articles, but in this one:

    http://www.lemonskin.net/io/11564

    It starts with a data-mfn=”3″. I never specified that number anywhere. There’s only one footnote. In the article text there’s nothing about footnotes.
    The block code is:

    <p>Da questo libro ho estratto la pianta che mi è servita a riprogettare <a rel="noreferrer noopener" href="http://www.lemonskin.net/io/11310#interni" target="_blank">gli interni</a> del Falcon. E sempre con questa guida ho scoperto dove sono posizionate le capsule di emergenza e che il cannoncino ventrale estraibile si trova da tutt’altra parte rispetto a dove lo ha piazzato Lego.<mfn>Ma si tratta di una scelta comprensibile, dettata dalla mancanza di spazio e dalla complessità del meccanismo di fuoriuscita.</mfn></p>

    Plugin Author prismtechstudios

    (@prismtechstudios)

    @locksoft thank you for all of this great detail, this is very helpful. I’ll look into all of these and get back to you!

    Thanks.

    Other issue: Once you added a Footnote with the toolbar button, you can edit it only in HTML mode. If you start writing inside the footnote is “cut”.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘An option to use normal text as shortcode’ is closed to new replies.