Support » Plugin: Simple Google reCAPTCHA » An error of type E_PARSE was caused in line 65 of the file

  • Resolved buggbugg

    (@buggbugg)


    I woke up to this email.
    Everythign seems to be ok now I am just wondering if I should be worried or not.

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, Simple Google reCAPTCHA.

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.5.1
    Current plugin: Simple Google reCAPTCHA (version 3.7)
    PHP version 5.6.40

    Error Details
    =============
    An error of type E_PARSE was caused in line 65 of the file /home/mysite/public_html/wp-content/plugins/simple-google-recaptcha/simple-google-recaptcha.php. Error message: syntax error, unexpected ‘?’

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Minor

    (@minor)

    Hi @buggbugg,

    It’s because you are using PHP version 5.6 and not 7.1 as required by this plugin.

    Anyway I fixed it, it was just a little change. You can reinstall this plugin now and it should work on version 5.6 too!

    Thread Starter buggbugg

    (@buggbugg)

    Thanks, although I am on PHP version 7.4.10 (Supports 64bit values) [confirmed by checking wp-site health-tool-server info]
    I am not sure why the email I first got said I am on 5.6.40

    • This reply was modified 1 year, 2 months ago by buggbugg.
    Plugin Author Minor

    (@minor)

    You had really php 5.6, because on version 7.1+ there is support for “null coalescing operator”. Anyway after reinstall the plugin it should be ok in php 5.6 too, because I’ve changed the code.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘An error of type E_PARSE was caused in line 65 of the file’ is closed to new replies.