Support » Plugin: Contact Form 7 » An error occurred while uploading the file.

  • Resolved mrmut

    (@mrmut)


    Everything works with smaller files. But when I try larger ones, I get

    An error occurred while uploading the file.

    Is there something trivial I need to check?

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Where can we see the website?

    Unfortunately the site is on the intranet, not accessible from outside. I did find a PHP error:

    koji je postavio/la require(‘wp-blog-header.php’), wp, WP->main, WP->parse_request, do_action_ref_array(‘parse_request’), WP_Hook->do_action, WP_Hook->apply_filters, rest_api_loaded, WP_REST_Server->serve_request, WP_REST_Server->dispatch, wpcf7_rest_create_feedback, WPCF7_ContactForm->submit, WPCF7_Submission::get_instance, WPCF7_Submission->submit, WPCF7_Submission->before_send_mail, do_action_ref_array(‘wpcf7_before_send_mail’), WP_Hook->do_action, WP_Hook->apply_filters, CFDBIntegrationContactForm7->saveFormData, CF7DBPlugin->saveFormData
    [21-Feb-2020 09:01:51 Europe/Zagreb] CFDB Error (2020-02-21 09:01:51 +01:00): CFDB Error: could not save uploaded file, field=fotografija, file=C:\wamp64\www/wp-content/uploads/wpcf7_uploads/0331051898/15822720694481081790867.jpg

    mrmut

    (@mrmut)

    Any guidelines what to do? Is this CF7 limit or on CFDB side?

    Thanks

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    As you can see in the error message it is a CFDB Error.

    No, it was actually your plugin; there is some kind of built in limitation.

    Maybe CF7 pulls WP file upload limit as default? The upload failed exactly when it was over 2 MB.

    I checked both MariaDB/MySQL logs and PHP logs, and while the error pointed to CFDB, there was no limitation on the server side – both blob size and max upload size on PHP side were set more than sufficiently high (I think 64 MB).

    What solved the problem is setting the file limit in CF7 to very high value. I tested a form with file upload only without any file size restriction, and the error was the same. When I set the file size deliberate lot very high byte value (100000000) the form worked.

    Apparently, it is a known issue. I found the solution somewhere on the internet based on the same problem description.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.