Support » Installing WordPress » [an error occurred while processing this directive]

  • Holy Cow. I’m completely lost.

    My WP blog went down three or four days ago, after a fantastico upgrade to v. 2.1. At first I was getting a DB error message, but I got on the phone tonight with Bluehost, and we created a new DB user, and got the blog to appear. I thanked Bluehost, hung up, and tried to log into admin.

    Once I tried to do that, however, everything fell apart, and now any effort to connect with either the blog or the admin portion results in the message that is shown in the topic title.

    Of course, I see now that my reliance on fantastico was foolish. But having incredibly messed up, what can I do? I am absolutely clueless!

    Thanks in advance for any help you can provide.


    The blog, by the way, is at

Viewing 14 replies - 1 through 14 (of 14 total)
  • If you have access to phpmyadmin, the first thing to do is get a dump (backup) of your database. Good tutorial on that here: but if that’s too much for under this sort of stress, get back with bluehost and ask them to do it for you.

    Note that there is a chance that you will have some corruption in the database. Hopefully not. But be prepared. Another thing to ask bluehost: if they have a backup of your data etc. BEFORE the date you did the fantastico upgrade.

    Once you accomplish those steps, then we can think about where to go next.

    Thank you, Varkyl. I’m on the phone with bluehost now, and the tech is trying to figure out if he can cut the db out of the last backup, which was at 10:30 this morning. That will be after the fantastico installation though. So, one way or another, I should have a recent backup fairly soon. I hope. 🙂

    Where do you think it would need to go next?

    many thanks!


    Hmmm. Ok, the latest. Bluehost found that all of my databases were corrupt (including the non-WP databases), and fixed them, so the site is back up. I still can’t log in, however. When I try, it just grinds away and does nothing, which is what it was doing right before it crashed last time. So I’m uncertain what this means — if I need to reinstall some WP files related to admin or log in, or what.

    To summarize, this what has happened:

    1. For several days I got a database error message;

    2. Earlier this evening another tech at bluehost helped me overcome that by adding another mysql user.

    3. A few minutes after the site came back up, it crashed again as I was trying to log in.

    4. After the last tech repaired the DBs, the site is back up, but it is still not letting me log in. I assme that is something in the WP installation, but I don’t know what.

    Any thoughts?

    do you have access to your database through phpMyAdmin?? if you have, follow the following:

    1. assuming that you didn’t change anything during install, select wp_users on left panel, and once the structure shows at the right panel, select Browse from the top.

    2. after selecting Browse, and the contents of the table appears, select [or click] the pencil to edit your record…

    3. delete the contents of user_pass and type in a new password, not forgetting to select MD5 under Function.

    4. click Go

    that should let you log in to your wp-admin now using your old username and your new password…


    the link you gave is showing a “Could not connect to remote server” error…

    Works fine for me. :>)

    now it is working fine, too… a minute ago, it just gave me the error message even after several refresh… sheesshhh… 😛

    It is a very strange situation. Last night Bluehost worked on it for a long time, and then concluded it was not a db problem, but a wordpress problem. So, this morning, I completely reinstalled WP 2.1, after first deleting every plug in and theme I had on my old set up. After I first did that I got a DB error message, but created a new user and modified my config file, and the blog reappeared.

    Unfortunately, when I tried to access the admin area, it refused to let me in. Its not that I get a screen or anything. Instead, when I click on admin, it tries to connect with the site, but never succeeds. And then, several minutes later, it reverts to what you will see now if you go there, which I think of as the white screen of death.

    I don’t know where to go. WP 2.1 has been completely reinstalled, with no plugins or themes other than what it came with, yet the problem persists. Any thoughts?

    For whatever it is worth, I am unable to reach my phpmyadmin page through the control panel. I was having trouble doing that last night as well.

    Wow. I’m afraid I haven’t any more advice – I’m not even using 2.1, and haven’t ever personally had a problem like this with 2.0….

    Wait, that’s not really true. I had exactly this problem some time back – but it wasn’t just wp, it was everywhere trying to login; sometimes it did just what you’re describing, sometimes it simply refreshed the login page…. but that was an upgrade to Zone Alarm Suite that caused it, and returning to ZA free fixed it…. So unless that points you in a new direction, I’m no help at all, sorry.

    Wow — I do run zone alarm, although it never did anything like this before. Do you have any idea how I might tweak ZA to try to address that?

    The ZA forum had some supposed “workarounds”. I did every last one of them with no result. The only fix for me was simply to eat the money I paid for ZA Suite (they refused to refund it) and go back to using ZA free which works just fine.

    I got the same error from bluehost. I think they are working on their backend systems. When outages occur they routinely tell the customer that it’s a user software problem when really they know perfectly well it is a problem with their own server.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[an error occurred while processing this directive]’ is closed to new replies.