Support » Fixing WordPress » An error occurred in the upload. Please try again later

  • I have a TinyMCE editor on the front end of my site so users can add posts. Everything is working perfectly except that the file uploader (the new one, in 3.5) is not letting anyone upload files. It just gives the error “An error occurred in the upload. Please try again later.”

    But, it’s only spitting out the error for non-admins. If I’m logged in as an admin, I can upload image just fine from the front-end.

    I have tried disabling all plugins. No help. I am using a modified twenty eleven theme. Still doesn’t work.

    It seems like it’s a user-permission-based problem, but I don’t know what user-permission (besides upload-files) would help me here.

    Any help would be awesome. Is this a bug in 3.5 or something? I’ve seen many people with variations of this problem since the update but no solution that works for me.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Moderator t-p



    I already went through that whole thread. There’s nothing on it that helps me.


    Moderator Andrew Nevins


    Forum moderator

    Does the problem persist in the original Twenty Eleven theme?

    It’s difficult to check because the problem occurs on the front end of the site and if I switch back to the regular theme, the custom page with the post form is no longer present, so I can’t test it. The theme I’m using is based on the twenty eleven theme.

    The media library works perfectly fine on the admin side and on the frontend IF I’m logged in as an administrator. The only time it does not work is if I’m logged in as anything lower than admin, which is why I think it’s some sort of permissions thing.

    I have the same problem. I can upload files as admin, but when my users try to upload files wordpress gives the following error:
    “An error occurred in the upload. Please try again later”.

    @mascheronicadteam – per the forum guidelines, please start your own thread. You’ll be more likely to get help and the forums work better when each person has their own thread.

    I have made a little bit of progress on this thread at WpQuestions:

    It’s still not working for me though. It looks like it might be a bug in WordPress 3.5. I’m thinking of downgrading until this gets fixed.

    This procedure worked for me:

    1) Deactivate all your plugins
    2) Reinstall wordpress …/wp-admin/update-core.php
    3) Activate all your plugin one by one and check if it works
    4) In my case the problem source was pointelle plugin.

    Thanks, I’ll try that. Is your problem occurring on the frontend of your site or the admin end?

    The problem occurs on both ends.
    Which front end plugin are you using?

    I’m actually using a custom front-end solution built by a developer specifically for my site.

    After playing around some more, I’ve definitely determined that this is a user capability issue. I can fix the issue by giving the user role some pretty advanced capabilities. I will post back here once I figure out the magic combination.

    I did try deactivating all plugins and re-installing, etc, but it’s still happening. On my end I don’t think it’s a plugin issue.

    I figured it out! The problem was the Theme My Login plugin, which has the ability to allow users access to the wp-admin area based on their user role. I figured out that if the role didn’t have that access, it also killed their ability to upload files on the front end.

    The problem was, even after deactivating the plugin, the setting were not clearing out of the database, so the behavior was still occurring with all plugins deactivated.

    Anyway, I have sent a note to the developer of Theme My Login to see if the may be able to fix this in the next update. In the meantime I just set all new users to “Author” and removed all the important permissions so if they do end up on the admin side, they won’t be able to do anything. Not ideal, but it works for now.

    I have some problem with wp 3.5 on

    Hi, I had the same problem in which I could post in the frontend using admin role but not others, and after some time debugging, I found out which are the minimum roles for the user required to have the upload working properly:


    It is particularly weird that edit_published_pages and edit_others_pages capabilities are needed, I guess this is a bug from WP

    Moderator t-p


    @apwidodo: Despite any similarity in symptoms, your issue is likely to be completely different because of possible differences in physical servers, hosts, plugins, theme, configurations, etc. Also, It’s easier for volunteers to help you if you have your own topic. Therefore, as per the Forum Welcome, please post your own topic. Posting in an existing topic prevents from being able to track issues by topic. 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘An error occurred in the upload. Please try again later’ is closed to new replies.