Support » Plugin: WP-Optimize - Cache, Clean, Compress. » An error occurred in the upload. Please try again.

  • Resolved halvorsenj

    (@halvorsenj)


    As long as my WP-Optimize plugin is active, I get this message uploading images to my website: An error occurred in the upload. Please try again.

    In the media overview, the uploaded file is not shown until refresh my browser.

    Basically, the file gets uploaded, but I cannot add it to my page before I refresh the browser. Therefore the error message is partially false.

    I tested with all my plugins active, except WP-Optimize, and the error only occurs with WP-Optimize is active.

    I tried disabling automatic compression. No joy.

    My upload folder settings says I have both read and write access.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Harshad

    (@bornforphp)

    @halvorsenj
    Could you send me a copy of your server’s PHP Error log?
    You can find this log through your web hosting control panel (typically cPanel). If you are unsure where to find the PHP Error log, you can ask your hosts to provide it.

    Thread Starter halvorsenj

    (@halvorsenj)

    I did another upload and caught this error in cPanel:

    [Mon Jul 05 09:23:23.762235 2021] [:error] [pid 791518:tid 47926859376384] [client 92.221.32.68:61502] [client 92.221.32.68] ModSecurity: Warning. Match of "pmFromFile path_excludes" against "REQUEST_FILENAME" required. [file "/etc/apache2/conf.d/modsec_vendor_configs/imunify360-full-apache/005_i360_4_custom.conf"] [line "905"] [id "77140992"] [msg "IM360 WAF: Suspicious access attempt (WP folders)!||SC:/home/digilean/public_html/wp-admin/async-upload.php||T:APACHE||REQUEST_URI:/wp-admin/async-upload.php||"] [severity "NOTICE"] [tag "service_i360custom"] [tag "noshow"] [hostname "www.digilean.com"] [uri "/wp-admin/async-upload.php"] [unique_id "YOKza7UONkmxi-VFpmV6YQAAgRQ"], referer: https://www.digilean.com/wp-admin/upload.php

    Plugin Support Harshad

    (@bornforphp)

    @halvorsenj It looks like module named ‘mod_security’ enabled on the server, could you please ask your host to temporary turn off the module and then try to upload the images and check if it works?

    Thread Starter halvorsenj

    (@halvorsenj)

    I disabled ModSecurity and tried again. The same problem persist, but I didn’t get any error logs when the upload failed.

    I then enabled ModSecurity again, got the same problem, but also the error log.

    [Wed Jul 07 12:58:31.995150 2021] [:error] [pid 384877:tid 47926967592704] [client 92.221.32.68:51622] [client 92.221.32.68] ModSecurity: Warning. Match of "pmFromFile path_excludes" against "REQUEST_FILENAME" required. [file "/etc/apache2/conf.d/modsec_vendor_configs/imunify360-full-apache/005_i360_4_custom.conf"] [line "905"] [id "77140992"] [msg "IM360 WAF: Suspicious access attempt (WP folders)!||SC:/home/digilean/public_html/wp-admin/async-upload.php||T:APACHE||REQUEST_URI:/wp-admin/async-upload.php||"] [severity "NOTICE"] [tag "service_i360custom"] [tag "noshow"] [hostname "www.digilean.com"] [uri "/wp-admin/async-upload.php"] [unique_id "YOWI16IChAc33TFseA0kSgAARwE"], referer: https://www.digilean.com/wp-admin/upload.php

    Plugin Support Harshad

    (@bornforphp)

    @halvorsenj So are the images uploading fine now?

    Thread Starter halvorsenj

    (@halvorsenj)

    Same as before: I upload the images and get the error message. However, the image is uploaded, but I must refresh my browser to see and use it.

    Plugin Support Harshad

    (@bornforphp)

    @halvorsenj Have to tried to disable other plugins except WP-Optimize and see if the issue still persists?

    Thread Starter halvorsenj

    (@halvorsenj)

    Yes, I have tried all other plugins. The problem only comes as long as WP-Optimize is enabled.

    Plugin Support Harshad

    (@bornforphp)

    @halvorsenj Can you please check if “Automatically compress newly-added images” option is enabled from WP-Optimize > Images, If yes, then can you please disable the option and then try to upload the images and check if you still get the message from WordPress?

    Thread Starter halvorsenj

    (@halvorsenj)

    Initially, the “automatically compress newly added images” was active.
    Before I reported this issue, I disabled it, but it did not change the behavior of the problem.

    danielbmusic

    (@danielbmusic)

    I’m having what appears to be the same problem. When I refresh the screen, the upload shows up. Just confirming the issue. I haven’t done all the deactivating other plugins, etc., but it sounds like the problem may still exist…

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.