WordPress.org

Forums

WP-Piwik
An error occured: Piwik did not answer. Please check your entered Piwik URL (3 posts)

  1. mafia2013
    Member
    Posted 2 years ago #

    it keeps encounter this error while i set every option correctly. and i run the test script but no result. dont know why. any help is appreciated

    http://wordpress.org/extend/plugins/wp-piwik/

  2. mafia2013
    Member
    Posted 2 years ago #

    correct url and auth token. it works fine when i host my site on goadddy but error occurs when i migrated to hostgator. so i am not sure if its the issue of hostgator end. btw, when i rerun the test script and there are different results as below:

    *** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
    Result:
    HTTP/1.1 403 Forbidden
    Date: Mon, 24 Jun 2013 12:35:04 GMT
    Server: Apache
    Content-Length: 400
    Content-Type: text/html; charset=iso-8859-1

    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /analytics/
    on this server.</p>
    <p>Additionally, a 403 Forbidden
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    <hr>
    <address>Apache Server at xxxxx.com Port 80</address>
    </body></html>

    Time: 0.07s

    *** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
    Result:
    HTTP/1.1 403 Forbidden
    Date: Mon, 24 Jun 2013 12:35:04 GMT
    Server: Apache
    Content-Length: 400
    Content-Type: text/html; charset=iso-8859-1

    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /analytics/
    on this server.</p>
    <p>Additionally, a 403 Forbidden
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    <hr>
    <address>Apache Server at xxxxx.com Port 80</address>
    </body></html>

    Time: 0s

  3. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Your issue is regarding your server configuration. See the error code returned by the test script: HTTP/1.1 403 Forbidden.

    Please check your apache configuration and your htaccess file. Try to set an user agent (Settings->Piwik). Maybe request from localhost/127.0.0.1 are blocked? Ask your host for detailed help.

    Btw.: See the FAQ regarding HostGator: http://wordpress.org/plugins/wp-piwik/faq/

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Piwik
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags