Support » Plugin: MailPoet - emails and newsletters in WordPress » An error has happened while performing a request, please try again later.

  • After update 3.6.5, Unauthorized users can not subscribe to the newsletter, form widget, shortcode

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author MailPoet

    (@wysija)

    Hey, sorry for the late answer.

    We’re you able to solve your issue?

    I am having the very same problem.

    When I am not logged in, the subscription form throws an error saying that “An error has happened while performing a request, please try again later”. Thus, none of my visitors can subscribe to the newsletter. Has anyone found a solution to this problem?

    kelhara

    (@kelhara)

    I have the same problem, it’s a nuisance as no one can subscribe.
    Is there a solution somewhere? I can’t seem to find any.
    Thanks,
    Kel

    • This reply was modified 1 year ago by kelhara.
    itziarlabox

    (@itziarlabox)

    Hi Kelhara,

    In our case, we replaced the MailPoet subscription form by a similar form created with the Contact Form 7 plugin. There is an addon for this plugin (Add-on Contact Form 7 – MailPoet) that provides an option to signup for your newsletter from forms created with Contact Form 7.

    Our new form is working perfectly.

    Good luck,

    Hi,

    I have the same issue with Mailpoet 3.
    I always used Mailpoet 2 before and everything was fine. Now that I’m using Mailpoet 3, visitors are no more able to subscribe !!!
    I’m using a form defined by using Mailpoet tools (in the admin section of Mailpoet).

    When I’m logged in as admin, I’m able to add a user thanks to the form. Perhaps this is due to the Members plugin that I have added to be able to manage Mailpoet from the Shop manager role?
    But I did not see any settings in the Members admin to modify for this?

    Any idea?
    Regards
    Pat

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘An error has happened while performing a request, please try again later.’ is closed to new replies.