WordPress.org

Support

Support » How-To and Troubleshooting » An appropriate representation of the requested resource /wp-admin/options.php

An appropriate representation of the requested resource /wp-admin/options.php

  • jobymathai
    Member

    @jobymathai

    Hello,

    When I try to add links in the Update Services section of word press, I am getting the following error
    ———-
    An appropriate representation of the requested resource /wp-admin/options.php could not be found on this server.
    ————

    I can add 10 links. But more than that I can’t add the links. I disabled the mod_security. Still I am getting the same error.

    Please advice me.

    Thanks,
    Joby

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Samuel Wood (Otto)
    Keymaster

    @otto42

    So you added SecFilterEngine Off to your .htaccess to disable mod_security, yes?

    Have you also tried closing your browser and restarting it, or clearing the browser cache? That can happens sometimes, I’ve seen browsers cache redirect responses.

    saadipathaan
    Member

    @saadipathaan

    I am having the same problem on my newly formed blog – here is the error which I am getting;

    Not Acceptable

    An appropriate representation of the requested resource /blog/wp-admin/options.php could not be found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I searched the error on google and found that I need to edit .htaccess file and add the following code into it;

    <ifModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </ifModule>

    so my blog’s .htaccess file looks like this;

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    <ifModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </ifModule>

    # END WordPress

    but still it does not resolves my problem~ I double checked the file in the specific directory it is there but still the same issue!!! ~ can anyone help me out over here??? =(

    regards.

    Moderator Samuel Wood (Otto)
    Keymaster

    @otto42

    Put that code into a new .htaccess file in your wp-admin directory only, not into the root .htaccess file.

    saadipathaan
    Member

    @saadipathaan

    I’ve deleted the old file and re-write the .htaccess file again – still the same problem. And yes, it’s path is mydomain.com/blog/.htaccess

    Jeremy Clark
    Member

    @jeremyclark13

    No what otto said was put the sec.. rules in a new .htaccess in your wp-admin directory.

    saadipathaan
    Member

    @saadipathaan

    oh sorry! lemme try that =)

    saadipathaan
    Member

    @saadipathaan

    nope~ not still not working ~ put new .htaccess in wp-admin folder with this code;

    # BEGIN WordPress

    <ifModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </ifModule>

    # END WordPress

    still the same problem!! =(

    Moderator Samuel Wood (Otto)
    Keymaster

    @otto42

    Ask your host if they have mod_security enabled and if it’s possible to disable it on a per-directory basis. They may have it set to where you can’t turn it off.

    I do not know of anything else that creates a 406 error, so I’d say that the answer has got to revolve around that in some way.

    Regardless, you’re going to have to talk to your host. Or get a new host.

    saadipathaan
    Member

    @saadipathaan

    I see, let me issue a ticket for that on their tech support.

    Thanks a lot for all the help, really appreciated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘An appropriate representation of the requested resource /wp-admin/options.php’ is closed to new replies.