An apostrphe in text causes text after it to drop off (3 posts)

  1. AdrianaU
    Posted 3 years ago #

    On two new sites we've had an issue when text has an apostrophe in it. When text with an apostrophe is added in the editor and the page is published or updated the editor drops everything after the first apostrophe it encounters.

    We've tried using the Microsoft Word tool and we've tried taking our text and first placing it in Notepad to strip out any hidden formatting and make it plain text but neither of those things have worked.

    We have had to hard code all apostrophes as "’" to work. Dashes and quotes must also be hard coded as "–", "—", ”" or "“" to not become question marks or cause text to drop off.

    We've also noticed that once we have added any hard coding if we switch in the editor from the "text" view to the "visual" view the editor will drop all our hard coded characters and again drop off everything after the first apostrophe.

    This wasn't an issue with any of our older WordPress sites, just these two newer ones.

    What do we need to do on these new sites to be able to add text in the editor without these issues?


  2. Krishna
    Posted 3 years ago #

  3. kmessinger
    Forum Moderator
    Posted 3 years ago #

    If you don't want to add a plugin try
    ◾deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Also remember to deactivate any plugins in the mu-plugins folder if you have one.
    ◾switching to the Twenty Eleven theme to rule out any theme-specific problems.

Topic Closed

This topic has been closed to new replies.

About this Topic