Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » An AMP component ‘script’ tag is present, but unused.

  • Resolved technicaljayendra

    (@technicaljayendra)


    I got this error on my all amp pages.

    I installed GOOGLE SITE KIT Plugin and use it’s recommended feature to place ads (auto ads using google site kit)

    It adds code on amp pages as well please help me to fix this issue.

    What should I do?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Thanks for reaching out. I’ll test this out with the same AMP plugin you are using to check for the same issue. In the meantime can you share your Site Health information privately using this form, with the AdSense module connected so I can check your current setup?

    Thread Starter technicaljayendra

    (@technicaljayendra)

    Okay, I did that please check it out.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for sharing. I’ve checked your details and all looks good. Most likely the script tag you are referring to is as a result of the amp-story-tag component.

    Can you inform me if the same issuer persists if you temporarily deactivate Site Kit? Let me know once you do deactivate Site Kit so I can check your setup (before you reactivate).

    Note I also tested the AMP for WP plugin on a site with AdSense and I was unable to recreate the same issue.

    Thread Starter technicaljayendra

    (@technicaljayendra)

    First of all I installed a amp for WP plugin and then I use Google site kit feature called insert auto ad code to enable Google auto ads and then I also enable ampauto ads and Google auto ads both using AdSense.
    I did not place any code in amp for WP plugin by Ahmad khaludi.

    Thread Starter technicaljayendra

    (@technicaljayendra)

    Yes when I uninstalled Google site kit plugin problem was solved and when I reinstall it problem arises again

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for the update. I’d like to check your site details with Site Kit temporarily deactivate. Can you let me know once you have Site Kit temporarily deactivated so I can check your site once more?

    Thread Starter technicaljayendra

    (@technicaljayendra)

    check form

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for sharing. It looks like since you shared your last Site Health information here the Site Kit plugin is active once more. Can you please perform one of the following and we can perform some more troubleshooting:

    1. Inform me whether you encounter the same validation error when checking any AMP URL on your site with Site Kit deactivate.
    2. Deactivate Site Kit temporarily once more and inform me here once deactivated.
    Thread Starter technicaljayendra

    (@technicaljayendra)

    After deactivating that plugin my issue was fixed on all pages but when I re-enable it issue Aries again on all pages.

    Plugin Support James Osborne

    (@jamesosborne)

    Interesting, thanks for sharing. I can see the following in your AMP URLs, resulting in a validation error although it’s not something I can replicate from my side using the same AMP plugin.
    <link rel="preload" as="script" href="https://cdn.ampproject.org/v0/amp-story-player-latest.js">

    This AMP component isn’t part of the Site Kit plugin. As I’m on your site at present can you temporarily deactivate the Site Kit plugin and I can check your site once more?

    Thread Starter technicaljayendra

    (@technicaljayendra)

    I did that at my and please check it out now on let me know

    Plugin Support James Osborne

    (@jamesosborne)

    Many thanks for sharing. I don’t see any validation errors also from inspecting your site at present. Feel free to reactivate the Site Kit plugin which I try and recreate this issue from my side.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for your patience. I’ve been trying to recreate the same issue with the same plugins without success. In order to troubleshoot this further can you share the following:

    1. Do you encounter the same validation error with just the Search Console module active in Site Kit? You can temporarily deactivate the Analytics and AdSense modules by navigating to Site Kit > Settings > Connected Services
    2. Do you have any additional extensions or pro features activated within your AMP for WP configuration?
    Thread Starter technicaljayendra

    (@technicaljayendra)

    I got that issue when I enable adsense auto ads placement option that found in Google site kit.

    Everything was fine before placing auto ads code using this plug-in

    I’m not using any pro functionality of ampforwp.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for providing an update. If you’re happy to perform more troubleshooting steps the below would be useful to determine if it’s the Auto ads for AMP specific:

    1. Temporarily disconnect the AdSense module within Site Kit
    2. Activate Auto ads for AMP using your AMP plugins configuration
    3. Check for the same issue.

    If you can inform me once you’ve performed the above I can also check from my side before you reconnect the AdSense module within Site Kit.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘An AMP component ‘script’ tag is present, but unused.’ is closed to new replies.