Support » Plugin: Unyson » An active PHP session was detected by the plugin Site Health

  • Hello ThemeFuse @unyson,

    please can you update your plugins, it give error with Rest API.

    An active PHP session was detected by the plugin Site Health:

    “A PHP session was created by a session_start() function call. This interferes with REST API and loopback requests. The session should be closed by session_write_close() before making any HTTP requests.”

    Thanks and thank for this plgins and your work.

Viewing 7 replies - 1 through 7 (of 7 total)
  • What is the plan here? A serious security threat warning has been issued about this. wplike75 raised the support query 4 days ago however there is no response? Is this app being run by a creche group or is this part of a serious operation? What is the route to resolving this? SUPPORT IN THE NEXT FEW SECONDS WOULD BE GREAT?

    I went to the GITHUB page like the alert states and found this, which resolved my issue.

    corzel commented 5 days ago
    I fixed it adding:
    session_write_close();
    in lines 231 and 262 in this file: wp-content/plugins/unyson/framework/includes/hooks.php

    229: session_start();
    230: }
    231: session_write_close();
    232: }

    nicolenik

    (@nicolenik)

    I had the same issue in my site and your solution has resolved it ! Thank you so much!

    Thanks

    Thanks man, that solved it. I hope they fix it in their next update.

    Thank you! I just discovered the same issue and this was helpful!

    @bcklick thanks!

    Direct link to the correct file: here. Just replace code of file and error will disappear.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘An active PHP session was detected by the plugin Site Health’ is closed to new replies.