WordPress.org

Support

Support » Plugins and Hacks » Events Manager » [Resolved] AM/PM Times Incorrect

[Resolved] AM/PM Times Incorrect

  • Whenever I have an event that is from AM to AM it never shows up correctly. For instance, I have an event from 10am – 12pm. It shows up as 10am – 12am. This goes for every single event that is within the same am or pm time EVEN THO IT IS CORRECT ON THE EVENT POST ITSELF. Here’s our events page: Events Page. Notice that the Day 2 Pray are all wrong! Thanks!

    http://wordpress.org/extend/plugins/events-manager/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Marcus

    @netweblogic

    Works for me… could it be that your formatting/placeholder settings of times are wrong? If you can post a screenshot somewhere of your default event list format and time formats, that may help.

    hmm, I tried this one and works for me too;

    I tried:
    #_EVENTTIMES
    #_12HSTARTTIME – #_12HENDTIME

    Plugin Author Marcus

    @netweblogic

    i think i know…

    in file http://www.lifecommunitychurch.net/wp-content/uploads/event-list1.jpg

    you are using #A in both places, the second one shoudl be #@A

    I suggest using #_EVENTTIMES instead of that, but the above fix would work fine too i think.

    Marcus,

    Thank you so much for your help. I got it corrected by using just the #_EVENTTIMES and everything looks great! Appreciate it!!!!!

    This might be a dumb question, I just noticed something…there is an extra space under date/time here: Events. My codes are below:

    Default event list format header:

    <center><img src="http://www.lifecommunitychurch.net/wp-content/uploads/images/events-header.jpg"><p></center>
    <table cellpadding="0" cellspacing="0" id="current-events">
    <thead>
    <tr>
    <th id="event-time" width="300" ALIGN= left>Date/Time</th>
    <th id="event-description" width="*" align=left>Event Description</th>
    </thead>

    <tbody>

    Default Event List Format:

    <tr>
    <td>#M #j #Y #@_{ \u\n\t\i\l M j Y}
    #_12HSTARTTIME - #_12HENDTIME
    <td>
    #_EVENTLINK
    <i>#_LOCATIONNAME, #_LOCATIONTOWN #_LOCATIONSTATE</i><p>
    </td>
    </tr>

    [Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum’s parser.]

    Unless your code got mangled by the forum, looks like the last code chunk has a </td> missing from under the third line. Should be:

    <tr>
    <td>#M #j #Y #@_{ \u\n\t\i\l M j Y}
    #_12HSTARTTIME - #_12HENDTIME
    </td>
    <td>
    #_EVENTLINK
    <i>#_LOCATIONNAME, #_LOCATIONTOWN #_LOCATIONSTATE</i><p>
    </td>
    </tr>

    Yes, that is the correct code. Tried your code and still having the issue. I noticed if I remove the <p> after the location info it moves everything under date/time up but then there’s no space between each event.

    <tr>
    <td>#M #j #Y #@_{ \u\n\t\i\l M j Y}<br>
    #_12HSTARTTIME - #_12HENDTIME
    </td>
    <td>
    #_EVENTLINK<br>
    <i>#_LOCATIONNAME, #_LOCATIONTOWN #_LOCATIONSTATE</i><p>
    </td>
    </tr>

    this maybe a different topic and should be posted on a new thread; however, try something like

    p:empty {display:none;} in your theme style.css

    Plugin Author Marcus

    @netweblogic

    you don’t have a closing p tag, that may be the problem

    i’d do as angelonwl suggested and make new posts for different problems, as the original question is resolved

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] AM/PM Times Incorrect’ is closed to new replies.
Skip to toolbar