Support » Plugin: jQuery Pin It Button for Images » Ampersand in site title populates pins with & amp ; (without spaces)

  • Resolved David G. Johnson

    (@haveanepiphany)


    I love this plugin. We’re using it on multiple sites. Thanks for the great work!

    On one site, we use an ampersand in the site title. I’ve done a fair amount of research about this and I believe I’ve narrowed the issue down to this plugin as other functions on the site seem to handle the ampersand properly.

    The issue is this: when a user clicks the “Pin it” button, the plugin populates the text (description) area of the new “Pin” with the contents of the page title — which, in our case, includes the site title and its accompanying ampersand. The ampersand, however, is rendered as & in the text of the pin rather than as the & itself.

    Here’s a link to a post that will exhibit the behavior if the “Pin it” button is used:

    Good Health is Sexy

    Any ideas? Thanks in advance for your help.

    https://wordpress.org/plugins/jquery-pin-it-button-for-images/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Marcin Skrzypiec

    (@mrsztuczkens)

    Hi,

    from what I can see you’ve fixed the issue on your own. Just curious: what did you do?

    Hi mrsztuczkens, thanks for the response.

    Actually, I have no explanation for this. Between the time I started this topic and the time I saw your response, I can think of absolutely nothing that has changed on the site.

    In fact, I just tested the “Pin It” button to confirm, and it appears that the issue has been resolved.

    I’m sorry I don’t have more info for you. You’re welcome to message me privately if more info would be helpful for the purposes of supporting your plugin.

    Thanks again!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Ampersand in site title populates pins with & amp ; (without spaces)’ is closed to new replies.