Support » Plugin: AMP » AMP Warning with these plugins

  • Resolved dschitra

    (@dschitra)


    Warning: The following plugins may be incompatible with AMP: jetpack, advanced-ads, insert-headers-and-footers, google-analytics-dashboard-for-wp, uk-cookie-consent More details

    what is meant by this warning?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Pascal Birchler

    (@swissspidy)

    This is just a heads up notification by the plugin.

    When you activate the AMP plugin, it performs an initial validation of your site to see if there are any AMP compatibility issues. Then, it tries to find out which plugins are responsible for these issues and then lets you know about them.

    If you click on the “More details” link you’ll see the AMP validation errors that have been found and lets you act on them. For example, you can then tell the plugin to remove invalid markup automatically for you.

    You can read more about this whole debugging workflow in our documentation at https://amp-wp.org/documentation/developing-wordpress-amp-sites/wordpress-amp-debugging-workflow/.

    Hope that helps!

    Plugin Support James Osborne

    (@jamesosborne)

    @dschitra Most likely you are receiving those warnings as the plugins listed add custom JavaScript to your site (resulting in validation errors not yet marked as “accepted”), or alternatively your theme or plugin(s) are causing you to reach the 50KBs CSS limit (after tree shaking).

    Can you try the following.
    – If you are using AMP Transitional mode then you can tick the ‘Validation Handling’ box to ensure all validation errors are accepted.
    – If using Standard mode please visit the “Validated URLs” tab and accept all validation errors.
    – Check temporarily with another theme active if the above fails.

    If the above doesn’t solve your issue please share your site and we can troubleshoot further.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.