Viewing 15 replies - 1 through 15 (of 17 total)
  • Same issue as well…

    Plugin Author pagefrog

    (@pagefrog)

    Hi franku,

    Thanks for sharing the errors! I’ll go through them one-by-one to help get them fixed, but you’ll see they are all caused by the same thing:

    1. Invalid attribute values: href=http://fonts.googleapis.com/css?family=Merriweather:400,400italic,700,700italic|Open+Sans:400,700,400italic,700italic, rel=wp_lightbox_prettyPhoto, src=http://cdn.ampproject.org/v0.js, src=http://cdn.ampproject.org/v0/amp-analytics-0.1.js
      Explanation: AMP requires that you load their scripts (v0.js, and amp-analytics-0.1js) and fonts over SSL. It looks like you have some plugin or function that is changing your scripts and fonts to http rather than https.
    2. Unkown syntax errors: amp-analytics extension .js script required by amp-analytics
      Explanation: Because the amp analytics file is being changed from https to http, the validator thinks that the tag doesn’t exist.
    3. Required tags missing: amphtml engine v0.js script
      Explanation: Same as above, because amp is being loaded over http rather than https, the validator thinks the script is missing

    Do you know where you have some code that might be removing the SSL? Is it in a plugin? Or functions.php? I am currently working on an option that would allow you to automatically solve these errors, I just want to make sure it covers your use-case. The fix will be available in v1.0.7.2.

    Hi Pagefrog,

    I have worked out it is the WordPress HTTPS plugin which we need for our checkout pages.

    This pluging is at https://wordpress.org/plugins/wordpress-https/

    I disabled the plugin and it validates

    Hi Pagefrog – thank you for your help – I have switched to a different https plugin at https://wordpress.org/plugins/ssl-insecure-content-fixer/ which solved these issues.

    I will mark this resolved now.

    Actually, there is other issues this plugin is causing – is it possible to get pagefrog to work with the WordPress HTTPS plugin at https://wordpress.org/plugins/wordpress-https/ ?

    we’re using the ssl insecure content fixer, but when you’ve got a change like this, there’s bound to be coding issues that will happen from other plugins too.

    We have a developer to get us through the errors as our Related Plugins created many rel= errors from the intext links (which provides outbound links) and Livefyre was throwing an HTTP error too.

    It’s going to be difficult for PageFrog and the AMP plugins to be able to fix a lot of these errors as they are coming from other plugins which may not be getting updates. Google made it sound like upgrading to AMP was going to be as easy as 1,2,3 but in reality it’s going to be a headache for a large percentage of us.

    Many people don’t even realize that they have errors as they aren’t even looking at their Google Webmaster tools. They’ve just installed the AMP plugin thinking that it is doing fine. Over time, the reality will hit a lot of people as it for many of us now.

    Plugin Author pagefrog

    (@pagefrog)

    Hi Franku, kutuliskan, and gooma2,

    AMP errors are most often caused by some of the plugins you’ve installed. Most older plugins are not AMP compatible, so you’ll get a lot of errors. For example, AMP doesn’t support javascript, so plugins that injects script tags will throw an error.

    If you update to the latest version of PageFrog, you’ll find a new feature called “Force AMP Compliance” which will disable conflicting plugins on AMP pages to avoid these errors. You’ll find this under Mobile Formats > Settings, it’s a checkbox near the bottom of the page.

    I know disabling plugins you’re used to having around isn’t ideal, but it’s been an effective way to quickly resolve AMP errors.

    If you update to the latest version of PageFrog, you’ll find a new feature called “Force AMP Compliance” which will disable conflicting plugins on AMP pages to avoid these errors. You’ll find this under Mobile Formats > Settings, it’s a checkbox near the bottom of the page.

    This stops AMP pages from being generated – All we get is a blank page both in preview and live page views.

    Yes, the Force AMP Compliance causes more problems than it fixes sadly.

    Plugin Author pagefrog

    (@pagefrog)

    Hi PPNSTeve and gooma2,

    The good news is, the Force AMP Compliance approach has solved problems for some users. Since most issues are caused by plugins, this feature blocks them to prevent conflicts on AMP pages.

    Bad news seems like it wasn’t the perfect solution since it seems to be causing issues for you still. I took a look at your website, PPNSteve, and many of the errors are definitely caused by some of the plugins you have activated on your site that’s being carried over to AMP.

    Force AMP Compliance should in theory fix the errors, but it seems like it’s causing a different error now if you’re getting a blank page.

    Are you able to go into debug mode and show me any php errors?

    Also gooma2, if you could give me more details on what kind of problems Force AMP Compliance is causing for you, that would be very helpful as well.

    Plugin Author pagefrog

    (@pagefrog)

    For anyone else experiencing issues regarding a blank page, these errors are usually caused by PHP errors. If you could share with me your PHP error log, that would help me solve the issue.

    For those unfamiliar with generating PHP errors logs, here’s a plugin that makes it really easy to generate PHP error logs https://wordpress.org/plugins/error-log-monitor/

    Once you get a list of PHP errors, please send them to me here or at team@pagefrog.com!

    Hi Pagefrog,

    Can you please have that feature prevent the wordpress https plugin from stopping any https links on pages (such as google analytics and google fonts etc.) with /amp in the url?

    This would also solve a lot of issues for a lot of people including us.

    We not seeing ANY php errors on this.. it just seems to do nothing, and makes a white (empty) page.

    The ONLY php error logged recently is:

    [13-Mar-2016 10:35:52 UTC] PHP Warning:  fopen(http://upload.wikimedia.org/wikipedia/en/9/94/Yugioh_Trading_Card_Game_Logo.png): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
     in /home/[redacted]/public_html/wp-content/plugins/amp/includes/lib/class-fastimage.php on line 31

    If this helps, here is a list of all active plugins we’re using:
    Active Plugin List
    ————————-===============———————–
    404 to 301
    Akismet
    AMP
    Auto Limit Posts Reloaded
    Contact Form 7
    Custom Meta Widget
    Custom Sidebars
    Disable XML-RPC
    Error Log Monitor
    Facebook Instant Articles & Google AMP Pages by PageFrog
    Fourteen Colors
    Glue for Yoast SEO & AMP
    Google Analytics Dashboard for WP
    Google Captcha (reCAPTCHA) by BestWebSoft
    Nested Pages
    NextGEN Gallery by Photocrati
    No Page Comment
    Really Simple CAPTCHA
    Responsive Lightbox
    SB Child List
    Scroll Top
    Simple Sitemap
    Simple Social Buttons
    Social
    Social Media Widget by Acurax
    TinyMCE Advanced
    White Label CMS
    WP Limit Login Attempts
    WP Smush
    Yoast SEO

    If this helps anyone…

    Problems with CloudFlare and AMP

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.