• Resolved wellmadedigital

    (@wellmadedigital)


    When using the free version of this plugin, we get the following error on every page except the home page when validating AMP:

    The tag 'noscript enclosure for boilerplate' appears more than once in the document.

    Has anyone else had this issue? It’s absolutely related to this plugin, because when we deactivate it, the issue is solved. I’m not sure if it’s a configuration error on our end since this plugin states support for the AMP for WP plugin, which we’re also using.

    Thanks for the feedback!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    WPSSO Core uses <noscript></noscript> containers to add second-level Schema markup.

    You can activate the WPSSO JSON add-on to add Schema markup as JSON-LD blocks instead of noscript containers, or you can disable the use of noscript containers by unchecking the SSO > General > Google > Meta Property Containers option.

    js.

    Plugin Author JS Morisset

    (@jsmoriss)

    FYI – When an AMP plugin is active, and the current webpage is an AMP page, the AMP_QUERY_VAR constant should be defined when viewing that page, and WPSSO Core should not add <noscript></noscript> containers to that webpage.

    I just double checked an AMP webpage created by the accelerated-mobile-pages plugin, and there are no <noscript></noscript> containers apart from the one added by the accelerated-mobile-pages plugin itself. Are you sure that you’re validating the AMP webpage url?

    Which AMP plugin are you using exactly? https://wordpress.org/plugins/amp/ or https://wordpress.org/plugins/accelerated-mobile-pages/ or another AMP plugin?

    js.

    wellmadedigital

    (@wellmadedigital)

    Thanks for the rapid response, @jsmoriss!

    Your first answer was spot on: it was the Meta Property containers option that was causing the AMP validation error when working in conjunction with https://wordpress.org/plugins/accelerated-mobile-pages/. Deactivating it looks like it worked, and our AMP pages are returning as valid again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.