Support » Plugin: AMP for WP - Accelerated Mobile Pages » AMP Update Warning

  • Resolved lancecarr

    (@lancecarr)


    Users are reporting various errors on sites that have updated the base AMP plugin created by Automattic NOT the AMP for WP plugin.

    If you see an update available for the AMP plugin DO NOT update yet until Automattic fixes the bugs in the latest release which is version 0.5.

    If you have already updated and are experiencing problems go to this URL:
    https://wordpress.org/plugins/amp/advanced/

    Scroll to the bottom of the page and select to download version 0.4.2.

    Remove the updated version and re-install the 0.4.2 version and you should be OK.

    REMEMBER! The WP AMP plugin is not causing this problem so you don’t need to touch it.

    • This topic was modified 11 months, 2 weeks ago by  lancecarr.
    • This topic was modified 11 months, 2 weeks ago by  lancecarr.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Yes, thank’s it’s work.

    I think if the “AMP” plugin don’t work with “AMP for WP”, then AMP for WP must make it’s plugin working by himself with clone of “AMP”.

    Strange, i don’t understand why the team of “AMP” plugin do update without test with “amp for wp”.

    @pierreto

    The reports of errors are coming from the AMP plugin by Automattic page as well.

    People who are not using the WP AMP plugin are also reporting the errors so this is an AMP by Automattic problem.

    Ok, thank’s.
    This kind of bug is quite rare on wordpress it’s strange to send update without test.
    The saturday bug fever

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    We apologize for the inconvenience. Everything is ready, We are pushing an update in less than an hour.

    Regards,
    Ahmed

    Plugin Author Mohammed Kaludi

    (@mohammed_kaludi)

    Hey @lancecarr and @pierreto,

    Thank you very much for reporting the issue.

    As @lancecarr mentioned, it is not our plugin that broke the site, it is the update of AMP plugin by Automattic that broke the code, in the change log you can see “- Fix: PHP Warnings from register_customizer_ui (props jahvi)”

    But we have acted on it quickly fixed the code according to their updated code and pushing the update to our plugin as well.

    Files are uploading as we speak,

    Thank you very much for reporting the issue.

    Mohammed kaludi

    The issue has been reported on https://github.com/Automattic/amp-wp/issues/747

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘AMP Update Warning’ is closed to new replies.