Support » Plugin: AMP » AMP Template Mode changes automatically

  • Resolved ACh

    (@ach1992)


    Hello,
    I installed the AMP plugin and I chose the Standard Mode or Transitional Mode but after I save settings is automatically changed to Reader Mode!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    That’s odd behavior indeed. Does the theme you’re currently using feature it’s own AMP reader mode templates, if so there may be some functionality that defines the active mode.

    If you’d like to share your site URL or Site Health information here or privately we can check your current setup and theme.

    Thread Starter ACh

    (@ach1992)

    I use the Jannah theme.

    
    ### wp-core ###
    
    version: 5.6
    site_language: en_US
    user_language: en_US
    timezone: Asia/Tehran
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/webcomec/public_html/elearno
    wordpress_size: 61.27 MB (64246739 bytes)
    uploads_path: /home/webcomec/public_html/elearno/wp-content/uploads
    uploads_size: 14.17 MB (14863347 bytes)
    themes_path: /home/webcomec/public_html/elearno/wp-content/themes
    themes_size: 23.49 MB (24625933 bytes)
    plugins_path: /home/webcomec/public_html/elearno/wp-content/plugins
    plugins_size: 19.98 MB (20954535 bytes)
    database_size: 2.77 MB (2909386 bytes)
    total_size: 121.69 MB (127599940 bytes)
    
    ### wp-active-theme ###
    
    name: ACh Child (ACh-child)
    version: 1.0.2
    author: A. Ch
    author_website: https://ach.li
    parent_theme: ACh (ACh)
    theme_features: core-block-patterns, TieLabs_Instagram_Feed, automatic-feed-links, title-tag, html5, post-thumbnails, Arqam_Lite, wp-block-styles, align-wide, editor-style, menus, widgets
    theme_path: /home/webcomec/public_html/elearno/wp-content/themes/ACh-child
    auto_update: Disabled
    
    ### wp-parent-theme ###
    
    name: ACh (ACh)
    version: 5.2.1
    author: ACh
    author_website: https://ach.li
    theme_path: /home/webcomec/public_html/elearno/wp-content/themes/ACh
    auto_update: Disabled
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.1, author: the WordPress team, Auto-updates disabled
    
    ### wp-plugins-active (9) ###
    
    ACh Toolkit: version: 1.1.2, author: ACh, Auto-updates disabled
    Advanced Editor Tools: version: 5.6.0, author: Automattic, Auto-updates disabled
    AMP: version: 2.0.9, author: AMP Project Contributors, Auto-updates disabled
    Classic Editor: version: 1.6, author: WordPress Contributors, Auto-updates disabled
    Jannah - Extensions: version: 1.0.13, author: TieLabs, Auto-updates disabled
    kk Star Ratings: version: 4.1.7, author: Kamal Khan, Auto-updates disabled
    Rank Math SEO: version: 1.0.56, author: Rank Math, Auto-updates disabled
    Schema Pro: version: 2.2.3, author: Brainstorm Force, Auto-updates disabled
    TieLabs Instagram Feed: version: 1.0.2, author: TieLabs, Auto-updates disabled
    
    ### wp-plugins-inactive (1) ###
    
    Jannah Speed Optimization: version: 1.0.9, author: TieLabs, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 512M
    upload_max_filesize: 512M
    max_effective_size: 512 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-962.3.2.lve1.5.31.el7.x86_64 x86_64
    httpd_software: LiteSpeed
    php_version: 7.3.23 64bit
    php_sapi: litespeed
    max_input_variables: 3000
    time_limit: 3000
    memory_limit: 1024M
    max_input_time: 6000
    upload_max_filesize: 512M
    php_post_max_size: 512M
    curl_version: 7.72.0 OpenSSL/1.1.1h
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.29
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/webcomec/public_html/elearno/wp-content
    WP_PLUGIN_DIR: /home/webcomec/public_html/elearno/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### amp_wp ###
    
    amp_mode_enabled: reader
    amp_reader_theme: legacy
    amp_templates_enabled: post
    amp_serve_all_templates: This option does not apply to Reader mode.
    amp_css_transient_caching_disabled: false
    amp_css_transient_caching_threshold: 5000 transients per day
    amp_css_transient_caching_sampling_range: 14 days
    amp_css_transient_caching_transient_count: 26
    amp_css_transient_caching_time_series: 
    	20210108: 23
    amp_libxml_version: 2.9.7
    
    
    • This reply was modified 10 months, 4 weeks ago by ACh.
    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for providing the additional info. It looks like your theme does feature it’s own AMP templates, and it may not be fully compatible in transitional or standard mode.

    To check this please try and disable AMP from your theme configuration (full documentation here) and check whether you’re then able to switch modes?

    Thread Starter ACh

    (@ach1992)

    Thank you for your response.
    I think the problem is the theme. I will send a ticket to theme support.

    • This reply was modified 10 months, 4 weeks ago by ACh.
    Plugin Support James Osborne

    (@jamesosborne)

    No problem, let us know if you have any further queries on this.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘AMP Template Mode changes automatically’ is closed to new replies.