Support » Plugin: AMP » ?amp not working for pages

  • My Google search console is giving error that pages are not amp. I have amp enabled for pages.

    Today I checked the amp url and found that it redirects to the non amp page. This problem is happening only on pages except homepage.

    So, I request you to fix this asap.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I am stuck with AMPs @wordpress plugin as well, the problem we got is : We have the plugin activated in Transitional mode. The AMP URL generated is without a trailing slash in the end of thre URL and with parameter -> ?amp, and yet the page only validates with a slash added -> /?amp/. But another issue is -> the original page generate the wrong rel=amphtml -> ?amp without a trailing slash in the end. Is there a way to fix it so that the AMP URL output has the trailing slash added, as required to validate the page? And how to make sure that the rel=amphtml generate the correct URL pointing to the amp variant.

    I hope someone here is able to help us both please. Our developer is struggling to solve the problem as well.

    Plugin Author Pascal Birchler

    (@swissspidy)

    @svetlanaw123 @seanlance Please share the URL to your website where this is happening so we can better assist you. Also, please share the Site Health information of your site so we can identify potential plugin and theme conflicts.

    Hi Pascal,

    Thanks very much for getting back to me on it, sorry i didn’t supply the URL beforehand, please take a look at: https://www.ortho-europe.com/product/alpha-smarttemp-liners/
    Not sure what do you mean by site health?
    I really hope to find a solution to this issue

    Many thanks
    Svetlana

    • This reply was modified 1 year, 2 months ago by svetlanaw123.
    Plugin Support James Osborne

    (@jamesosborne)

    @svetlanaw123 There could be a plugin or configuration setting not allowing your AMP URLs to render. To share your Site Health info you can find the settings from your WordPress dashboard under “Tools > Site Health“.

    • This reply was modified 1 year, 2 months ago by slance.
    Plugin Support James Osborne

    (@jamesosborne)

    @seanlance Perfect, now you just click on the “Info” option and then “Copy site info to clipboard” before pasting it in here.

    Sory, can’t post my entire site info in public!

    Plugin Support James Osborne

    (@jamesosborne)

    @seanlance Understood, can you ensure you have this setting ticked from your AMP configuration settings if you are using AMP in transitional mode.

    If you are not using reader mode or that doesn’t allow you to open your AMP versions you can try temporarily deactivate some of the plugins you have active, one by one before trying to open any AMP URL.

    @jamesosborne – site health info – 85% ->

    2 Recommended improvements

    You should remove inactive plugins
    Security

    Have a default theme available

    Plugin Support James Osborne

    (@jamesosborne)

    @svetlanaw123 There might be no problems identified via your Site Health Info, it can be useful at times to debug problems with AMP. But if you check the setting mentioned previously and try troubleshoot the AMP rendering issue by temporarily deactivating your plugins one by one you might be able to find the source.

    I will do @jamesosborne and let you know

    Thanks again

    Just now I activated transitional mode to check and then again changed back to reader mode. I tried editing pages and got 404 errors. I save changes to permalinks and deactivated amp plugin and then activate again. Now, my website is working.

    In case of errors before, seems like transitional mode is on for all pages except on homepage. But, I am on reader mode.

    It looks like I have to look for a paid option!

    • This reply was modified 1 year, 2 months ago by slance.

    We tried using transitional on our website bagogames.com and when checking whether the URL’s were valid or not Google said none of them were. It appears that Appending the AMP url with a ? mark is messing up the validation tool. We’d like to use the transitional phase, have both AMP and non-AMP versions of the site. How do we do that but have AMP display correctly without the ? mark. Thanks!

    P.S. We are currently using reader because we couldn’t figure it out.

    • This reply was modified 9 months, 2 weeks ago by Ajoyshop.
Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘?amp not working for pages’ is closed to new replies.