Support » Plugin: YAHMAN Add-ons » AMP is not working

  • Resolved Vidyut

    (@vidyut)


    Hi,

    I’m using this plugin, because it seems ambitious and interesting and can potentially replace several individual plugins. I began with testing AMP – the amp pages, served as ?amp=1 are not validating as AMP code in the tester.

    The same pages validate with the official AMP plugin.

    I am using your Neatly theme. I don’t think it is a theme issue though. The plugin doesn’t appear to be removing html that isn’t allowed in AMP. I can give a link, but since I can’t keep a production site with invalid code, I’ve activated the AMP plugin, so the code is valid. Deactivating AMP and relying on your plugin results in invalid code.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author YAHMAN

    (@back2nature)

    Thank you for report.

    In my test environment no problem.

    What’s that error condition?

    Vidyut

    (@vidyut)

    With only Official AMP plugin
    https://imgur.com/6YC8pWY

    With Official AMP plugin AND AMP activated in YAHMAN Add-ons
    https://imgur.com/ApkOosR

    With only YAHMAN Add-ons AMP
    https://imgur.com/WVdgLNy

    Your plugin is not removing invalid javascript, etc.

    Plugin Author YAHMAN

    (@back2nature)

    Thank you.
    Cause is javascript.

    But, I can’t understand that is how to output.

    Maybe you can turn off plugin one by one, see if you recognizes cause.

    If found out the plugin then may be able to solve.

    Plugin Author YAHMAN

    (@back2nature)

    Solved the problem that could not be detected depending on how to write Javascript in the article.

    It would be useful if the plugin can remove incompatible javascript when converting to amp. The other amp plugin does this. Otherwise the amp feature isn’t very useful, because one still ends up spending a lot of time troubleshooting.

    You may want to check how it does this.

    Plugin Author YAHMAN

    (@back2nature)

    Thank you for your advice.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘AMP is not working’ is closed to new replies.