Support » Plugin: W3 Total Cache » AMP extension- netto prices

  • Resolved grehgor

    (@grehgor)


    After installing the AMP extension in reading mode, only in the mobile version of the site, the prices of products show you the net (without VAT) – this is an error

    how to remedy this?

    Prices on the store in the mobile version should be gross as in the computer version

    Clearing the cache and disabling the plugin does not help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @grehgor

    I am sorry about the issue you are experiencing and I am happy to help.
    I am not sure I understand the issue so can you please elaborate on this? When you say AMP extension do you mean the extension in W3TC or the amp plugin?
    What plugin have you tried to disable?
    Please share more details so we can help you with this.

    yes, I mean extend W3TC to AMP and install the AMP plugin (https://amp-wp.org/)

    At the beginning it was like that when I cleared the cache, the correct prices returned for a moment. Now it doesn’t work anymore, so I removed taxes from the store to get the correct price.

    I didn’t use the AMP plug alone without W3TC, and I can’t tell which of these plugins introduced such an anomaly, or maybe both.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    Can you please share which plugin have you tried to disable?
    Also what AMP URL Type: and AMP URL Postfix: are you using?
    Can you please share the settings in Performance>Extensions>AMP Settings?
    Thank you!

    Hello,
    The two stores where I made this installation are already in production mode, so I quickly uninstalled everything and removed the tax rates to get prices back.

    That is why I cannot send an active link to the site.

    I can describe the settings:

    All components in the latest versions

    Woocommerce:
    – 22% tax
    – I introduce product prices with tax
    – displaying products with tax

    AMP plugin – (https://amp-wp.org/)
    – in “Reader” mode

    W3 Total Cache plugin
    – on factory settings

    main settings
    – Page Casche (on-disk)
    – Minify (on-disk)
    – Data base cache (on-disk)
    – Object cache (on-disk)
    – Browser cache (on-disk)

    Problems arose after two days of how AMP websites were created. I did not change anything in the links. Displaying the page, I entered the primary page address.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @grehgor

    Thank you for the information.
    You say that settings in W3 Total Cache were on “factory settings”.
    Have you enabled the extension in Performance>Extensions>AMP and change settings in the AMP extension according to match your URL Type: and AMP URL Postfix?
    Thank you.

    I enabled the AMP extension but did not change the URL to AMP URL

    Do you think prices have changed for this?

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @grehgor

    I believe that the issue is potentially related to minify, or if you have made some changes, and did not purge the cache those pages never got updated.
    In this case, you need to specify URL Type: and AMP URL Postfix in the AMP extension settings that you are using with the AMP plugin and make sure to purge the cache after any changes.
    Thank you!

    Hello,

    I found the cause of the price problem.
    Lack of default location in woocommerce gives prices in the store. So I set the default location to the store location and now it’s good.

    The reason was in the woocommerce settings.

    Thanks for trying to help and commitment.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @grehgor

    I am glad to know you managed to find the cause of the issue and thank you for sharing the solution!
    We would really appreciate it if you could take a minute and post a review here. This will help us to continue offering a top-notch product to users.
    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.