Support » Plugin: NextScripts: Social Networks Auto-Poster » amp error on 4.3.23

  • hi,
    Just to let you know that your plugin is generating errors on AMP pages on 4.3.23
    https://ibb.co/Zhcskt6

    with previous versions there were no compatibility problems
    have it installed on a lot amp sites, and the same problem
    only work fine amp pages when disable nextscripts

    If you can correct this, Thanks

    • This topic was modified 3 months, 2 weeks ago by x0ff.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author NextScripts

    (@nextscripts)

    Well, there is no way for us to fix this.

    But the good news is – this is a “false positive”.

    SNAP adds some Javascript code to the top “admin panel”. This code is loaded only when you logged as an admin. Which means you real AMP visitors won’t get this script and this error. Your validator is not smart enough to see that and since you are ruining it as an admin, it reports an error.

    Thread Starter x0ff

    (@x0ff)

    OK 🙂
    Thanks, @nextscripts

    Thread Starter x0ff

    (@x0ff)

    hi again,
    ask for support from the amp creators some days ago and they answered me this:
    https://wordpress.org/support/topic/false-positive-19/

    please, can you correct your plugin adding data-ampdevmod attribute?
    thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.