Support » Plugin: Wordfence Security - Firewall & Malware Scan » AMP error message jquery.min.js

  • Resolved hamil

    (@hamil1)


    My site is AMP. After updating to WordPress 5.6 I get the message “Invalid script: jquery.min.js” Source of the Wordfence Security plugin.
    This message was not on WordPress 5.5.
    Please advise how to fix it.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support wfpeter

    (@wfpeter)

    Hi @hamil1, thanks for getting in touch over this.

    I understand that you have already disabled Wordfence to clear the issue, however as Wordfence is fully WP 5.6 compatible I’m not yet entirely sure it is the source and instead might causing a conflict with another plugin. The reason I ask this is because we have a large quantity of customers running Wordfence successfully with this configuration. I have just installed AMP with my Wordfence installation, tested with “Transitional” and “Standard” templates and received no browser console errors or validation errors under the “Plugin Suppression” section of AMP.

    It may help in sites recently updated to WordPress 5.5 or above to install the Enable jQuery Migrate Helper plugin below to see if the issue is resolved:
    https://wordpress.org/plugins/enable-jquery-migrate-helper/

    If the above isn’t applicable, disable all plugins other than Wordfence and AMP to see if you’re able to replicate the issue. If so, reactivate your other plugins one by one to see if any further jQuery issues arise. You could also try switching your theme to a default such as WordPress’ Twenty Twenty-One theme in case the conflict is in scripts included by your theme rather than a plugin. I recommend activating a maintenance mode plugin during this time which allows you to do this, but not create strange results for other site visitors.

    Let me know how you get on!

    Thanks,

    Peter.

    Thread Starter hamil

    (@hamil1)

    @wfpeter Thank you for answer. First, I contacted the AMP plugin support forum https://wordpress.org/support/topic/invalid-script-jquery-min-js/. The Wordfence Security plugin seems to be causing the problem.
    On the test website https://moje.edilo.cz/ I have WordPress version 5.6.1, template Twenty Twenty-One Version 1.1. I left only the AMP and Wordfence Security plugins active. The others are deactivated. I reset Wordfence Security to its default settings.
    The problem still persists:

    Invalid script: jquery.min.js
    Details
    JS

    Wordfence Security
    Markup Status
    Removed

    Invalid script: jquery-migrate.min.js
    Details
    JS

    Wordfence Security
    Markup Status
    Removed

    Invalid inline script
    Details
    JS

    Wordfence Security
    Markup Status
    Removed

    Invalid script: admin.ajaxWatcher.1607007971.js
    Details
    JS

    Wordfence Security
    Markup Status
    Removed

    Plugin Support wfpeter

    (@wfpeter)

    Hi @hamil1, thanks for showing the list of scripts coming up for you.

    Is the AMP plugin only reporting a problem only for logged-in admins, and does the AMP plugin flag scripts only on the front end? If so, you could turn off the checkbox Front-end Website under Monitor background requests from an administrator’s web browser for false positives at the bottom of the Wordfence > Firewall > All Firewall Options page.

    The ajaxWatcher script is useful if an AJAX request is blocked while the admin is logged in, so you can whitelist it if needed, but if turning it off solves the problem and you’re not getting unexpected blocks to whitelist, it should be fine to leave it that way.

    Thanks again,

    Peter.

    Thread Starter hamil

    (@hamil1)

    @wfpeter Thank you. Errors do not appear when you turn off the Front-end Website. Problem solved.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘AMP error message jquery.min.js’ is closed to new replies.