Support » Plugin: Facebook Instant Articles & Google AMP Pages by PageFrog » /amp disappearing off the URL and not displaying the AMP post

  • Resolved kimstuart

    (@kimstuart)


    My AMP plugin works fine, this is the second site I’ve installed it on and used it successfully.

    I love the idea of your addition, but I can’t seem to get it to work.

    When I activate your plugin, the /amp at the end of the post is redirected to the original post and no AMP content is displayed.

    Does this need to be enabled on EVERY post in order for it to work properly? The AMP plugin enables all posts immediately, so does this negate that functionality?

    https://wordpress.org/plugins/pagefrog/

Viewing 15 replies - 1 through 15 (of 33 total)
  • the correct end of the url is /amp/
    with the ending slash

    not /amp

    bye

    c

    (@igneous)

    I can’t seem to get it to work on one of my installations either, but it works on all of my other sites. Can’t figure out why yet either because I have almost identical setups for all of these sites.

    It works just fine as /amp and no trailing slash without the PageFrog. I’ll try it and report back.

    Let me ask my question differently –

    If I use your plugin and do not have EACH post checked to use with the AMP HTML, does this prevent the AMP plugin from rendering the post as AMP?

    So ONLY the posts that I go and check off will render, and the rest will default to the non-AMP page instead?

    Plugin Author pagefrog

    (@pagefrog)

    Hi all,

    Thanks for the questions! You are correct that a post needs to be enabled for AMP before adding /amp/ will render the AMP HTML right now. If you’d like to enable all posts on your site, you can go to Mobile Formats > Settings. Then under the Google AMP section check all the post-types that you’d like to enable (or select all) and then click the Enable AMP button. Your posts will begin to automatically be switched to active.

    We wanted to include an enable/disable setting so that you could have the flexibility to test a subset of pages with AMP without being forced to dive head-first into it. Anyways, give that a try and let me know if it works for you! If you have anything go wrong or you can’t figure it out, feel free to send us an email at team@pagefrog.com

    Plugin Author pagefrog

    (@pagefrog)

    C, I’d love to hear a little more about the challenge that you’re having with your one site. Have you tried enabling all of your posts as well?

    c

    (@igneous)

    Yeah it took a while but it’s enabled for all 20,800+ posts on that site. But when I visit a post like x.com/post/amp/ it just redirect to x.com/post/amp

    on that same domain I have some other installations that are nearly identical, and are working just fine. Like x.com/site2/post/amp/ and they load the correct amp format. I can’t quite figure it out. They each have a couple different plugins, but nothing that I can see that would affect this behavior.

    I’m having a weird issue similar in that only the new articles published will direct to the AMP but older ones (pre-Feb. 11, 2016) just keep directing back ot the original article.

    We’ve cleared all cache completely, but the only thing that fixes the issue is when I deactivate this plugin. I am hoping to keep using this one as I like the Facebook & Apple News integration (since our site is on both).

    Just seeing if others have had similar or if it’s just a fluke only happening on our site: (https://movietvtechgeeks.com/)

    We also are using the AMP plugin along with Yoast Glue. We deactivated Glue and left this one on but the problem sadly doesn’t stop until the PageFrog plugin is deactivated.

    “We wanted to include an enable/disable setting so that you could have the flexibility to test a subset of pages with AMP without being forced to dive head-first into it. “

    Super smart idea, and now that we know, that helps 🙂

    I’ll make time later in the week to start tinkering with the PF plugin again, it looks really promising for a number of reasons —

    I’m getting this problem too, I have tried re-saving permalinks, I’ve tried with new articles and I’ve tried with old, they all just redirect. The only thing that works for me is using “?amp=1”, which is strange because I use pretty permalinks. Hoping that this isn’t stopping Google from recognising the pages, as after-all, that’s the main reason I’m using it.

    I did the re-saving permalinks too but it’s weird that the new articles are directing to AMP perfectly but ones from a couple weeks back won’t do it.

    We tried every variation of deactivating all plugins but the only one causing this issue is the PageFrog one. That’s the one I want to keep too.

    Yeah, I think there might be a bug somewhere, I haven’t tried disabling plugins as I haven’t had time yet, but its probably something widespread anyway, people probably just haven’t noticed yet.

    Looking at the HTML code, the head is also linking amp pages to the “/amp/” URL, so that means Google is going to have problems with the redirection, and it seems that for me, no page is loading with that URL, if it’s not a problem with the plugin then I’m going to do some bug fixing over the weekend, but I’m thinking that it is something to do with the plugin.

    if you’ve got the regular AMP plugin, then the easiest test is just to disable this one and see if you’re pages start redirecting to AMP. If they do, then you know the plugin is causing you issues too.

    We spotted the issue as our Indexed AMP pages started dropping the day after we installed this plugin, so we’re testing now to see if they go back up.

    Most people probably don’t realize they need to keep an eye on the Indexed AMP Pages in the Google Webmaster Tools along with the AMP pages with errors as that will let you know if there’s problems or not.

    Sure, I tried that I got the same results, however, I am currently unable to fully bug test (caches etc) as that would involve taking the site down for a bit, or reducing its performance.

    We also use Pagespeed and Redis, so it’s likely the conflict might be there, or it could be with the Yoast AMP plugin. Or something else entirely, maybe even WordPress in general.

    We only recently started using AMP so Google hasn’t indexed yet.

    Not to worry, if you do some Fetch and re-submits through Webmaster Tools, the big G will be happy to send you error notices on your AMP pages, since it will start crawling them.
    I got an error – missing image – on a page that Google found on its own, it’s definitely not something I requested a crawl for… and it’s only been 4 days since we installed the AMP plugin.

Viewing 15 replies - 1 through 15 (of 33 total)
  • You must be logged in to reply to this topic.