Support » Plugin: AMP » AMP and YOAST compatibility problem: not able to edit posts

  • Hi,
    We are facing this problem since some time now. We have pinned it down to the AMP plugin and Yoast. We use Newspaper theme and Yoast premium and AMP.

    When these are enabled together we are not able to edit any of the posts. server times out. Also, Admin panel slows down.

    If we disable yoast and keep amp running, we can edit posts.
    Also if we disable amp and keep yoast running we are able to edit posts.
    But together we are not able to.
    It is a compatibility problem, probably you need to work with yoast and solve the problem

    Please resolve the issue.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    @m3gadeath Apologies for the delay in responding. We are happy to look into this for you. I use Yoast myself with AMP so I can try and recreate the issue from my side. Can you confirm the same issue occurs when using an alternate theme?

    If you want to share your Site Health information I can try and recreate a similar setup.

    Thread Starter m3gadeath

    (@m3gadeath)

    Thanks for replying, it is happens with Newspaper theme. As soon as you enable it in the Newspaper theme panel. The workpress admin panel is really slow because of AMP+Yoast.

    Also, we tried it in other theme, it is slow, but it opens up.

    Site- health:

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: en
    user_language: en
    timezone: Asia/Kolkata
    permalink: /%category%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 56
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/w789XXXX6o4w7/public_html
    wordpress_size: 1.84 GB (1973845705 bytes)
    uploads_path: /home/w789XXXX6o4w7/public_html/wp-content/uploads
    uploads_size: 6.51 GB (6992788893 bytes)
    themes_path: /home/w789XXXX6o4w7/public_html/wp-content/themes
    themes_size: 9.11 MB (9555926 bytes)
    plugins_path: /home/w789XXXX6o4w7/public_html/wp-content/plugins
    plugins_size: 130.18 MB (136507078 bytes)
    database_size: 215.52 MB (225992251 bytes)
    total_size: 8.70 GB (9338689853 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Newspaper (Newspaper)
    version: 10.2
    author: tagDiv
    author_website: http://themeforest.net/user/tagDiv/portfolio
    parent_theme: none
    theme_features: amp, post-formats, post-thumbnails, automatic-feed-links, html5, woocommerce, bbpress, align-wide, align-full, editor-font-sizes, editor-style, menus, widgets
    theme_path: /home/w789tqn6o4w7/public_html/wp-content/themes/Newspaper
    
    ### wp-themes-inactive (1) ###
    
    Newspaper: version: 10.1, author: tagDiv
    
    ### wp-plugins-active (21) ###
    
    Akismet Anti-Spam: version: 4.1.3, author: Automattic
    AMP: version: 1.4.2, author: AMP Project Contributors
    Asset CleanUp: Page Speed Booster: version: 1.3.5.3, author: Gabriel Livan
    Classic Editor: version: 1.5, author: WordPress Contributors
    Cloudflare: version: 3.4.1, author: John Wineman, Furkan Yilmaz, Junade Ali (Cloudflare Team)
    OneSignal Push Notifications: version: 2.0.2, author: OneSignal
    Really Simple SSL: version: 3.2.7, author: Rogier Lankhorst, Mark Wolters
    reSmush.it Image Optimizer: version: 0.2.4, author: reSmush.it
    tagDiv Cloud Library: version: 1.4 | built on 11.11.2019 15:07, author: tagDiv
    tagDiv Composer: version: 2.5 | built on 11.11.2019 15:07, author: tagDiv
    tagDiv Mobile Theme: version: 1.3 | built on 11.11.2019 15:07, author: tagDiv
    tagDiv Social Counter: version: 4.7 | built on 11.11.2019 10:30, author: tagDiv
    tagDiv Standard Pack: version: 1.0 BETA | built on 11.11.2019 15:07, author: tagDiv
    TCBD Auto Refresher: version: 2.0, author: Md Touhidul Sadeek
    WebP Express: version: 0.17.2, author: Bjørn Rosell
    Wordfence Security: version: 7.4.5, author: Wordfence
    WorDroid: version: 1.0.0, author: Anubhav Anand
    WP-Optimize - Clean, Compress, Cache: version: 3.0.15, author: David Anderson, Ruhani Rabin, Team Updraft
    WP Rocket: version: 3.4.4, author: WP Media
    Yoast SEO: News: version: 12.4.1, author: Team Yoast
    Yoast SEO Premium: version: 12.8.1, author: Team Yoast
    
    ### wp-plugins-inactive (1) ###
    
    UpdraftPlus - Backup/Restore: version: 1.16.21, author: UpdraftPlus.Com, DavidAnderson
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1684
    imagemagick_version: ImageMagick 6.9.4-10 Q16 x86_64 2017-11-14 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 8 GB
    	imagick::RESOURCETYPE_DISK: 1.84467440737E+19
    	imagick::RESOURCETYPE_FILE: 12288
    	imagick::RESOURCETYPE_MAP: 8 GB
    	imagick::RESOURCETYPE_MEMORY: 4 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.70
    
    ### wp-server ###
    
    server_architecture: Linux 2.6.32-954.3.5.lve1.4.58.el6.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.2.20 64bit
    php_sapi: litespeed
    max_input_variables: 5000
    time_limit: 300
    memory_limit: 3548M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 64M
    curl_version: 7.62.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.44-cll-lve
    client_version: 5.6.44
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/w789XXXX6o4w7/public_html/wp-content
    WP_PLUGIN_DIR: /home/w789XXXX6o4w7/public_html/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 3524M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    [ Please do not bump. ]

    @m3gadeath sorry for the delay in reply. We’ve been testing on our side, but have not been able to recreate the issue. We’ll keep looking into this, but I was curious if you noticed any browser console errors while attempting to edit a post? Also, if you could see if your host has any error logs that may indicate what occurred when the server timed out that could be helpful. Thank you!

    Thread Starter m3gadeath

    (@m3gadeath)

    Thanks, we get server timed out error when we try to access post editor. When we disable amp, it opens ups in normally and no errors. It is only when yoast and AMP are enabled together on Newspaper theme.

    @m3gadeath thanks for the follow up. Could you share your hosting provider and plan?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘AMP and YOAST compatibility problem: not able to edit posts’ is closed to new replies.