Support » Plugin: Post SMTP Mailer/Email Log » Amazon SES API Signature Version 4

  • Resolved Nick

    (@sarrasn)


    Hi,

    I received this email from Amazon SES and was wondering how that will affect Posst SMTP plugin as I am using Amazon SES to send emails with your plugin:

    Amazon Web Services currently supports Amazon SES API requests that are signed using Signature Version 3 and Signature Version 4 processes. Signature Version 4 further enhances the security around authentication and authorization of Amazon SES customers by using a signing key instead of your secret access key. To improve the security for our customers, beginning October 1, 2020, Amazon Signature Version 3 will be turned off (deprecated) in Amazon SES in favor of Signature Version 4.

    Amazon SES customers who are still using Signature Version 3 must migrate to Signature Version 4 by September 30, 2020. After that, Amazon SES will only accept requests that are signed using Signature Version 4.

    About this subject, we have a reference from Amazon at

    https://docs.aws.amazon.com/general/latest/gr/signature-version-4.html

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author yehudah

    (@yehudah)

    Hi,

    Sorry for the delay, you are using SMTP – no affect.

    Nick

    (@sarrasn)

    So I have nothing to do in my Amazon SES account in order to adapt to this Signature Version 4?

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.