Support » Plugin: WP2Static » Amazon S3 Deploy Access Denied

  • Resolved honorconsulting

    (@honorconsulting)


    I’m having a very specific issue where site export is successful, but Amazon S3 Deploy is failing due to receiving a 403 error. Logs say Access Denied when it attempts to upload the first file. I am on version 6.6.6.

    The AWS Credentials I am using are from the account root user, so I’m not understanding why there would ever be a permissions issue.

    Anyone have a solution for this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Mark

    (@markwp2static)

    Hi there honorconsulting!

    Thank you for sending us a message here.
    We have a specific documentation about Amazon S3 and I hope it will help : https://docs.wp2static.com/en/deploying/deployment-options/amazon-s3/

    If not, I will leave this one open so that our senior plugin author can look into this.
    Thank you for your understanding and patience.

    Hi Mark. Thanks for the response. Yes, I’ve seen that documentation and am following those instructions. Also, I’ve checked the logs to make sure that the S3 endpoint and protocols all match up. I have also primed the S3 bucket with the directory folder in case that was the issue, which it appears not to be.

    Please let me know if you have any other suggestions. Thank you!

    Plugin Author WP2Static Team

    (@leonstafford)

    Hi @honorconsulting,

    There is an issue since about 6.3 or 6.4, that requires you to allow public ACL on buckets to be overridden (within AWS console > S3 > bucket permissions).

    This is because the plugin tries to explicitly set public-read access, which is required for static sites.

    Usually, this is set by a policy or other mechanism, so we’ll change this in next release of S3 add-on.

    Sorry for the extra headache.

    Cheers,

    Leon

    Leon,

    I really appreciate the assist.

    For anyone reading this, once you have a user that has the proper access levels to S3 and Cloudfront, which can be an IAM user or your root user, this just means that you need to check your settings in S3 > bucketname.com > Permissions > Block Public Access. Once there, you need to make sure that both of the options that control ACLs are both switched off.

    All is working well now. Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.