Support » Plugin: BackWPup - WordPress Backup Plugin » Amazon S3 Backups not wokring

  • Having issues with backing up to Amazon S3

    I’m on Dreamhost

    max_execution_time: 600

    Keeps stalling when creating tar.gz file

    Here is my working log:

    [INFO] BackWPup version 3.1.2; A project of Inpsyde GmbH
    [INFO] WordPress version 3.8.3
    [INFO] Blog url:
    [INFO] BackWPup job: WordPress Install Backup; FILE
    [INFO] BackWPup cron: 45 3 * * 0; Next: Sun, 1 Jun 2014 @ 03:45
    [INFO] BackWPup job started manually
    [INFO] PHP ver.: 5.3.27; cgi-fcgi; Linux
    [INFO] Maximum PHP script execution time is 20 seconds
    [INFO] Script restart time is configured to 600 seconds
    [INFO] Script restarts on every main step is activated
    [INFO] MySQL ver.: 5.1.56-log
    [INFO] curl ver.: 7.21.0; OpenSSL/0.9.8o
    [INFO] Temp folder is: /home/nicoleskeltys/
    [INFO] Logfile is: /home/nicoleskeltys/
    [INFO] Backup type is: archive
    [INFO] Backup file is: /home/nicoleskeltys/
    [26-May-2014 17:13:01] 1. Trying to make a list of folders to back up …
    [26-May-2014 17:13:01] 685 folders to backup.
    [26-May-2014 17:13:01] 1. Trying to generate a manifest file …
    [26-May-2014 17:13:01] Added manifest.json file with 6.63 kB to backup file list.
    [26-May-2014 17:13:01] 1. Trying to create backup archive …
    [26-May-2014 17:13:01] Compressing files as TarGz. Please be patient, this may take a moment.

    I’ve tried splitting up my backup jobs to the following

    WordPress Database
    WordPress Install
    WordPress Plugins
    WordPress Content
    WordPress Uploads
    WordPress Manual Uploads

    thinking it would help with the time it takes to generate the tar.gz file, but that hasn’t helped. I keep getting WARNING: Job restarts due to inactivity for more than 5 minutes.

    General Information
    WordPress version 3.8.3
    BackWPup version 3.1.2 Get pro.
    PHP version 5.3.27
    MySQL version 5.1.56-log
    cURL version 7.21.0
    cURL SSL version OpenSSL/0.9.8o
    WP-Cron url:
    Server self connect: Response Test O.K.
    Temp folder: /home/nicoleskeltys/
    Log folder: /home/nicoleskeltys/
    Server Apache
    Operating System Linux
    PHP SAPI cgi-fcgi
    Current PHP user nicoleskeltys
    Safe Mode Off
    Maximum execution time 20 seconds
    Alternative WP Cron Off
    Disabled WP Cron Off
    CHMOD Dir 0755
    Server Time 22:22
    Blog Time 17:22
    Blog Timezone
    Blog Time offset -5 hours
    Blog language en-US
    MySQL Client encoding utf8
    Blog charset UTF-8
    PHP Memory limit 256M
    WP memory limit 40M
    WP maximum memory limit 256M
    Memory in use 51.25 MB
    Loaded PHP Extensions: Core, PDO, Reflection, SPL, SQLite, SimpleXML, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dom, ereg, exif, filter, ftp, gd, gettext, hash, iconv, imap, json, libxml, mbstring, mcrypt, mhash, mysql, mysqli, openssl, pcntl, pcre, pdo_mysql, pdo_sqlite, posix, pspell, session, soap, sockets, sqlite3, standard, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

    Here is a screenshot of my Jobs Settings –

    I appreciate any help you can provide.

Viewing 1 replies (of 1 total)
  • Update:

    I’ve set the max execution script time within the BackWpup settings to 30 seconds and set the reduce server load to Medium.

    I also changed the compression from tar.gz to simply tar

    Now its at least fully generating the tar file, and connecting to Amazon S3, but its not actually uploading the file. Its stuck at 1% as seen here –

    I know my connection to Amazon is working as my daily database only backups are pushing out just fine and for what its worth, this website is hosted on a shared plan with Dreamhost.


Viewing 1 replies (of 1 total)
  • The topic ‘Amazon S3 Backups not wokring’ is closed to new replies.