WordPress.org

Support

Support » Plugins and Hacks » WP Offload S3 Lite » Amazon S3 and Cloudfront Not Uploading to Amazon

Amazon S3 and Cloudfront Not Uploading to Amazon

  • I have WordPress 3.8 installed and Amazon Web Services installed as a plugin on my website.

    I upgraded the PHP version of the server to be compliant (that was the first challenge) and defined the Access Key ID as well.

    The challenge is that when I upload an image, through wordpress, it just doesn’t get uploaded to Amazon. I had my web developer look at it and he thinks it may be just be that the plugin is not compliant with wordpress 3.8.

    Could you share if the plugin has been tested with 3.8? Or if there are additional steps I can take?

    Seems like a great concept, so really want to launch my store with it if possible.

    http://wordpress.org/plugins/amazon-s3-and-cloudfront/

Viewing 15 replies - 1 through 15 (of 31 total)
  • I’m having the same problem. Could it be a 3.8 thing?

    I’m having the same issue. I’m on 3.8 as well

    I’m having the same issue. It did work for me, but I’m not sure if I had already updated to 3.8. I Just updated to 3.8.1 in case that would make a difference, but it didn’t.

    Has anyone figured out a solution to get it to work with WP 3.8?

    I’m having the same issue with all my sites — haven’t been able to get the latest version of the plugin to upload (or even to update the URL to S3). No apparent errors – it just doesn’t seem to upload to S3…

    It works on WP 3.7.1 (single site localhost setup) but it’s not uploading files in a live multisite setup using WP 3.8.1

    Must be a 3.8 related issue

    I think this must be broken, as I haven’t been able to get it work and it looks like lots of other people are having the same issues.

    Does anyone have any workarounds? Are there any other plugins that do a similar thing which people have had success with?

    Plugin Author Brad Touesnard

    @bradt

    It’s working fine with my site on 3.8.1, so it’s not a WP core compatibility problem.

    Hi Brad,

    Thanks for responding! That’s good news. Is there anything else that can be done to debug this?

    Perhaps it’s related to something else — for example, in my particular case I upgraded from an older version of the plugin, to the latest -and then upgraded the WP core.

    This is not working on any of my 3.8.1 sites, so I think that there must be something odd going on here!

    Do you need me to send anything that could help debug it further?

    I’ll also try and set up a new WP site with no plugins installed and see if this works… Perhaps we can isolate it that way?

    Tom

    I’m creating a proof-of-concept site to test the viability of building the S3 CDN into all our WordPress sites. I set it up with the AWS credentials in the wp-config.php, and I had the same problem identified above. I removed the wp-config credentials and added them via the web form in the AWS plugin, and it worked.

    I used this page for config guidance (especially the IAM permissions policy)

    http://blog.celingest.com/en/2013/07/19/tutorial-creating-cdn-wordpress-cloudfront-s3/

    Hi

    Just confirming that I, too, have the keys entered in wp-config.php and the S3 plugin is not uploading the content. So maybe that is the issue?

    I use Amazon Opsworks to automatically deploy sites, so being able to have the keys entered in wp-config.php is quite important for me. Is anyone else able to verify that this is working only when entered into the web form?

    Thanks

    Tom

    @ssirag – That post you shared by Victor from blog.clingest.com did the trick!

    I thought since the plugin didn’t require a setup of cloudfront that it would work, but that was not the case for me.

    The changes that I made to get it working are:

    1. Set up cloudfront distribution
    2. Use the form to input the keys and removed them from wp-config.php
    3. I set up new user with the custom policy that was defined in the article.

    Thanks Brad Touesnard for a cool plugin and for everyone sharing their ideas on how to get it working.

    Hmm, it didn’t work for me. When I first installed the plugin, it worked for a few images, then stopped. Not sure if I updated wordpress before or after I installed it, or after.

    I originally put my key info in my wordpress config file. I took it out, input it from the form and tried again, but that didn’t make a difference for me.

    I just checked my error log, and it said:
    Error uploading /home/USERNAME/public_html/blog/wp-content/uploads/2014/02/amdad.jpg to S3: [curl] 6: Couldn’t resolve host ‘BUCKET-NAME.s3.amazonaws.com’ [url] https://BUCKET-NAME.s3.amazonaws.com/blog/wp-content/uploads/2014/02/amdad.jpg

    I got it to work!
    * I had already moved my access key info from my config file to the form.
    * I had a bucket policy that I deleted, and I put the same permissions for my IAM user as the link give by ssirag.
    * I deactivated all of my plugins except these two–and it still didn’t work.
    * So I looked in my database and found a few orphaned options from a plugin I had installed about a month ago, and then deleted.

    It worked! So not sure if deleting those database options did the trick, or if it was a combination of everything.

    Then I decided to test to see if I could move my access key info back to my config file–it didn’t work. I deleted it and put it back in through the form, and it worked again.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Amazon S3 and Cloudfront Not Uploading to Amazon’ is closed to new replies.
Skip to toolbar